Small-scale instance of Infinite Scale as a systemd service failed with nginx as proxy for apache2

I am running ocis 2.0 on a dedicated server with debian bullseye and nginx (listening on port 80 and 443) as proxy for apache2 (listening on port 8080).
After trying to login on the website h-t-t-p-s://[my_ocis_subdomain].[my_domain] I got the Apache2 Debian Default Page situated at /var/www/html.

Steps to reproduce

  1. run dedicated server with debian bullseye nginx as proxy for apache2
  2. install ocis according to this how to h-t-t-p-s://doc.owncloud.com/ocis/next/examples/small-scale.html#introduction, which went fine until the nginx end.

Expected behaviour

try open a web browser, navigate to your Infinite Scale URL h-t-t-p-s://ocis.example.com and log in as admin user with the password returned by the ocis init command.

Actual behaviour

After trying to login on the website h-t-t-p-s://[my_ocis_subdomain].[my_domain] I got the Apache2 Debian Default Page situated at /var/www/html.

Server configuration

Operating system: debian linux bullseye

Web server:
nginx as proxy for apache2
Database:
postgresql

Here are the system messages:

root@[myservername] / # systemctl status ocis.service
● ocis.service - OCIS server
Loaded: loaded (/etc/systemd/system/ocis.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2023-01-04 14:16:59 CET; 1min 55s ago
Main PID: 410559 (ocis)
Tasks: 14 (limit: 19049)
Memory: 103.0M
CPU: 724ms
CGroup: /system.slice/ocis.service
└─410559 /usr/local/bin/ocis server

root@[myservername] / # ./nx-status.sh
● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2023-01-03 23:00:17 CET; 15h ago
Docs: man:nginx(8)
Process: 357479 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
Process: 357484 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
Main PID: 357486 (nginx)
Tasks: 9 (limit: 19049)
Memory: 13.4M
CPU: 6.200s
CGroup: /system.slice/nginx.service
├─357486 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
├─357487 nginx: worker process
├─357488 nginx: worker process
├─357489 nginx: worker process
├─357490 nginx: worker process
├─357491 nginx: worker process
├─357492 nginx: worker process
├─357493 nginx: worker process
└─357494 nginx: worker process

Jan 03 23:00:16 [myservername] systemd[1]: Starting A high performance web server and a reverse proxy server…
Jan 03 23:00:17 [myservername] nginx[357479]: nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on 0.0.0.0:80, ignored
Jan 03 23:00:17 [myservername] nginx[357479]: nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on [::]:80, ignored
Jan 03 23:00:17 [myservername] nginx[357479]: nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on [::]:443, ignored
Jan 03 23:00:17 [myservername] nginx[357479]: nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on 0.0.0.0:443, ignored
Jan 03 23:00:17 [myservername] nginx[357484]: nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on 0.0.0.0:80, ignored
Jan 03 23:00:17 [myservername] nginx[357484]: nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on [::]:80, ignored
Jan 03 23:00:17 [myservername] nginx[357484]: nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on [::]:443, ignored
Jan 03 23:00:17 [myservername] nginx[357484]: nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on 0.0.0.0:443, ignored
Jan 03 23:00:17 [myservername] systemd[1]: Started A high performance web server and a reverse proxy server.

nginx -t
nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on 0.0.0.0:80, ignored
nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on [::]:80, ignored
nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on [::]:443, ignored
nginx: [warn] conflicting server name “[my_ocis_subdomain].[my_domain]” on 0.0.0.0:443, ignored
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

root@[myservername] / # ./a2-status.sh
● apache2.service - The Apache HTTP Server
Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2023-01-03 18:15:39 CET; 20h ago
Docs: h-t-t-p-s://httpd.apache.org/docs/2.4/
Process: 335153 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS)
Process: 361146 ExecReload=/usr/sbin/apachectl graceful (code=exited, status=0/SUCCESS)
Main PID: 335157 (apache2)
Tasks: 9 (limit: 19049)
Memory: 32.3M
CPU: 2.872s
CGroup: /system.slice/apache2.service
├─335157 /usr/sbin/apache2 -k start
├─361151 /usr/sbin/apache2 -k start
├─361152 /usr/sbin/apache2 -k start
├─361154 /usr/sbin/apache2 -k start
├─361155 /usr/sbin/apache2 -k start
├─361156 /usr/sbin/apache2 -k start
├─361157 /usr/sbin/apache2 -k start
├─361158 /usr/sbin/apache2 -k start
└─362069 /usr/sbin/apache2 -k start

Jan 03 18:15:39 [myservername] systemd[1]: Starting The Apache HTTP Server…
Jan 03 18:15:39 [myservername] systemd[1]: Started The Apache HTTP Server.
Jan 04 00:00:03 [myservername] systemd[1]: Reloading The Apache HTTP Server.
Jan 04 00:00:03 [myservername] systemd[1]: Reloaded The Apache HTTP Server.