Smb mount and some users get "No files in here"

smb
external_storage
9.1.x

#1

hi, I've just joined mailing list but in case it's quiet there, and it's somewhat urgent, I'm hoping here I can some help also.

I'm experiencing a bit bizarre (mis)behaviour of owncloud, or another component in the pipeline.
Users are LDAP back-end and they all log in just fine. I've created a SMB external storage and this storage works fine, but! only for some users!?
Some users get "No files in here" whereas there is data on that share.

First I thought - could it be LDAP defining, describing those users differently, but to my eye they seem virtually identical there in the LDAP.
Then I thought - maybe some other restrictions OS imposes on some users, but then I thought: owncloud does not go through it, it goes directly to Samba, right?

It is not filesystem permission (nor any other controlling mechanism) for, those users who get no files at the same time get to that same samba share simply by mapping a net drive, with no problems whatsoever.

I've been watching logs, samba's and Glusterfs's, as Gluster is the storage back-end Samba share uses, but nothing apparent there.
I need a hint on where, how, I can get bite into owcloud in order to troubleshoot this. Apache's log are pretty quiet.

All thoughts shared very appreciated.
L.


#2

Hi,

please fill out the issue template shown when creating a new thread in the "oC server" category. This is asking you various mandatory information about your environment (currently even the used ownCloud version is missing).

As you're using SMB external storages also make sure that you have https://github.com/eduardok/libsmbclient-php installed and enabled. Without this package external storages for SMB are not working reliable.


#3

What template? Only mandatory - and as I understand mandatory, will not do without - was Category. And tags seem optional.


#4

The following template shown if you start a new topic within the https://central.owncloud.org/c/help/oc-server category:

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

[b]Steps to reproduce[/b]
1.
2.
3.

[b]Expected behaviour[/b]
Tell us what should happen

[b]Actual behaviour[/b]
Tell us what happens instead

[b]Server configuration[/b]
Operating system:
Web server:
Database:
PHP version:
ownCloud version (see ownCloud admin page):
Updated from an older ownCloud or fresh install:
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

[b]ownCloud log (data/owncloud.log)[/b]

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info
[code]

[/code]

[b]Integrity status for oC9+[/b]

[code]
Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.
[/code]

#5

ok, the thing is that (just tried) if one goes for content text-box first and later for Category then... I did that.

Easy way to describe how env and how to reproduce it would be: Centros 7.3 everything from distro's repos + epel. And only extra is 3.8.10-1.el7.x86_64 from centos-gluster38.

No extra owncloud apps added/installed.

Samba share is:

[user.Docs]
kernel share modes = No
vfs objects = glusterfs full_audit
glusterfs:volume = USER-HOME
glusterfs:logfile = /var/log/samba/glusterfs-USER-HOME.%M.log
glusterfs:loglevel = 7
path = /%u
comment = my private files
browseable = no
writable = yes
guest ok = no
Veto files = /*backup*/*.raw/*.lnk/*.exe/*.com/*.dll/*.bat/*.vbs/*.mp3/*.m3u/*.m4a/*.m4p/*.wav/*.ra/*.avi/*.mp4/*.wmv/*.wma/*.mkv/*.mov/*.mpg/*.mpeg/*.vob/*.swf/*.rm/*.flv/*.asx/*.ace/*.zip/*.rar/*.sfx/*.iso/*.dmg/*.DS_Store/*..DSStore/*.DS_Store
;vfs objects = full_audit
full_audit:prefix = %u-%I-%m-%S
full_audit:failure = mkdir rmdir open write pwrite sendfile rename unlink ftruncate lock symlink readlink link mknod
full_audit:success = none
full_audit:facility = local5
full_audit:priority = notice

In the meanwhile I tried: put a no-files-in-here user into "domain admin" group(like this was going to help, yeah, right). And I have a user which not in that group and yet it works for the user.

I have:

'log_type' => 'owncloud',
'loglevel' => 1,

and still nothing "apparent" in the owncloud.log

But I have a suspicion there is something in LDAP. Only, if yes then what.


#6

Still missing but already asked above:


#7

ok, I think I've nailed the culprit, but first would have to try to understand inner workings of CIFS external storage - as an overview and in non-programmer terms. Would there be a doc describing what happens behind the cifs/external storege scenes?


#8

You can try your luck at https://doc.owncloud.org where all documentation about ownCloud is located.