SMTP gmail error


#1

Hello, happy to be part of this community. I explain my problem in the project that I am developing: I have owncloud running in docker, I am trying to configure the SMTP mail service with gmail in my owncloud settings but I get the following error:
sdsd

I tried different configurations that I found in this forum but it does not work for me. I need to activate this service to activate the application of records.
owncloud version: 10.0.10.4
a greeting and many thanks in advance


#2

Check if you have the 2 factor authentication in your google account. If so, you can try to disable it (probably not a good idea) or you can try to generate an application password in your google account.
In your google account, go to security and generate an app password for the mail. You’ll need to use that generated password instead of your “normal” password.

Note that I have only checked that it works, but I don’t know if there is any caveat about it. I’ve also read that you have a limit of 99 mails for a free account.

You can also try another mail service.


#3

Thank you very much, it was really that, activate access from unsafe applications and it worked. About the mail it is indifferent since it is a project for the school. If you do not mind (I do not know if to create another post), take the opportunity to ask about another error that is coming up: download and have the app registration (https://github.com/pellaeon/registration), this works, but once activated when accessing the settings panel I get an error HTTP ERROR 500 in the browser.
In the owncloud log I get the following:

**"time": "2019-02-07T13: 56: 05 + 00: 00", "remoteAddr": "10.0.2.2", "user": "administrator", "app ":" PHP "," method ":" GET "," url ":" \ / index.php \ / settings \ / admin "," message ":" Class OCA \\ Registration \\ Settings \\\\ RegistrationSettings contains 2 abstract methods and must therefore declared abstract or implement the remaining methods (OCP \\ Settings \\ ISettings :: getPanel, OCP \\ Settings \\ ISettings :: getSectionID) at \ / var \ / www \ / html \ / apps \ / registration \ / lib \ / Settings \ /RegistrationSettings.php#9 "}**

Thank you very much again.


#4

The app doesn’t seem to support ownCloud 10.0.10, assuming it worked with previous ownCloud version. You can try to contact with the app maintainer and then decide what to do, or you can try to fix the problems by yourself.


#5

Thanks man for the help