Smtp settings don't work

Hey,

I have Owncloud installed on the same Domain as a CMS software that uses mails all the time.
In the CMS sending mails works but when I use the same settings (double checked them 200 times) I get the following error message:

A problem occurred while sending the email. Please revise your settings. (Error: Connection could not be established with host dedivirt374.your-server.de :stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages: error:1408F10B:SSL routines:ssl3_get_record:wrong version number)

OwnCloud Community: 10.3.2.2
Server SSL: Let’s encrypt via Hetzner Manager Server which seems to be working perfectly since all my domains are secured with it and never fail to send/recieve mails.

Let me know if you need more information in order to give some advice on where to start looking for a solution.

Greez
luggie

Can you post screenshots of the mail settings in your CMS and ownCloud (you can blur out server names). I assume there is a difference in between SSL settings.

Are your CMS and ownCloud using the same PHP? (no funky PHP-FPM setup with multiple PHP version, with different modules enabled?)

This is why it is important you fill out the server issue template, because I could already see these kind of settings… Also please provide a configreport.

To have a more detailed error message in the ownCloud logs I recommend you set the following in your config.php:

'mail_smtpdebug' => true,
1 Like