[SOLVED] Desktop client entity too large rproxy

i’ve been using OC for a while and i’ve had a long standing issue since moving to the docker server where some files wont upload via the desktop client.
one file is a 26MB dll, another is a 57MB zip.

Web interface uploads these same files fine so i’ve not hit the typical .htaccess/php.ini limits. I’ve double checked and they are 256M/513M so far above my file sizes.

desktop client fails with ‘Server replied “413 Request Entity Too Large”’ for both these files. When i tested uploading via the web interface, the desktop client sucessfully downloaded without issue so it appears soly related to uploads.

Desktop client is Fedora31’s owncloud-client from the fedora repo’s (currently, although i know my Windows10 clients also have issues with the same dll.

what can i do to fix this upload issue?


i have put this into the search function of the forums on the top right corner and found various topics like e.g.:

How to change upload limits and fix upload problems (this has a note on the “Request Entity Too Large”)
Request entity too large
Request entity too Large Nginx server

It looks to me that various web server configuration options could be involved here which could cause this error.

while i am looking into it being reverse proxy, wouldnt these issues happen on uploading via the web interface too; same url used between client & web ui; so all data flows through the rproxy and adhear to the same limits surely?

This will happen if any of the involved HTTP servers configured to limit request body size.
For nginx, it is

client_max_body_size 10M; # At least

I’m using these settings personally:

fastcgi_keep_conn on;
fastcgi_socket_keepalive on;
fastcgi_buffering off;
fastcgi_request_buffering off;
client_max_body_size 32M;


from what i know / have read in the past there are two different upload mechanisms used by ownCloud:

The Web GUI is uploading a file as a whole where the ownCloud client is uploading a file in smaller “chunks” which has 10 MB each.

This could also explain the difference here, uploading many smaller chunks could saturate some web server / proxy buffers causing the “Request entity too large” message.

interesting info tom42. makes sense on why there’s a different.

i’ve tweaked my docker owncloud instance to allow direct http connections (for testing) and its allowing the 57MB zip file to be uploaded now.
Problem appears to be on the the rproxy side (docker letsencrypt), which uses nginx&php7. at least i’ve isolated whats actually causing the issue. I looked at the LE container with advice from AnrDaemon but couldnt find anything amiss on the server-wide config, but i’ve just remembered each rproxy service i run has it’s own config file so maybe the issue is in there…

1 Like


i use the letsencrypt container https://hub.docker.com/r/linuxserver/letsencrypt. While the nginx server & php was configured correct, the proxy.conf of nginx was not.
had to change the line in /config/nginx/proxy.conf from 10m and set it to the docker owncloud size of 513mb.

client_max_body_size 513m;

restart LE container and file uploading from desktop client is now working.