[SOLVED] "Error when assembling chunks" uploading large files to S3 folder

Steps to reproduce

I’ve installed OwnCloud on an EC2 instance, and then created a folder pointing to an S3 bucket.
The installation seems to be working fine.
However, whenever I try to upload a large file (> ~120MB) I get the error message “Error when assembling chunks”
Smaller files work fine, and larger files also work fine on other folders.

The quote of the user is unlimited

If I check the requests, the request having an issue has this information:
URL: https:///remote.php/dav/uploads//web-file-upload-/.file
Method: MOVE
Status: 500

Destination: https:///remote.php/dav/files///

Expected behaviour

The file should be successful uploaded

Actual behaviour

I get an error 500 instead “Error when assembling chunks”

Server configuration

Ubuntu 18.04

Web server:


PHP version:

ownCloud version: (see ownCloud admin page)
10.0.10 (stable)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:
Ubuntu repository

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

$CONFIG = array (
  'updatechecker' => false,
  'instanceid' => '<id>',
  'passwordsalt' => '<salt>',
  'secret' => '<secret>',
  'trusted_domains' =>
  array (
          0 => '<ip>',
          1 => '<domain>',
  'datadirectory' => '/var/www/owncloud/data',
  'overwrite.cli.url' => 'http://<ip>',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'owncloud',
  'dbhost' => '<dbhost>',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_admin',
  'dbpassword' => '<dbpassword>',
  'logtimezone' => 'UTC',
  'installed' => true,
 sudo -u www-data php occ config:list system
    "system": {
        "updatechecker": false,
        "instanceid": "<instance id>",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
        "datadirectory": "\/var\/www\/owncloud\/data",
        "overwrite.cli.url": "http:\/\/<ip>",
        "dbtype": "mysql",
        "version": "",
        "dbname": "owncloud",
        "dbhost": "<dbhost>",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "logtimezone": "UTC",
        "installed": true

List of activated apps:

  - comments: 0.3.0
  - configreport: 0.1.1
  - dav: 0.4.0
  - federatedfilesharing: 0.3.1
  - federation: 0.1.0
  - files: 1.5.1
  - files_external: 0.7.1
  - files_sharing: 0.11.0
  - files_trashbin: 0.9.1
  - files_versions: 1.3.0
  - files_videoplayer: 0.9.8
  - firstrunwizard: 1.1
  - market: 0.2.5
  - notifications: 0.3.5
  - provisioning_api: 0.5.0
  - systemtags: 0.3.0
  - updatenotification: 0.2.1
  - encryption
  - external
  - user_external

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

Client configuration

Tried in several: Chrome, Brave, Vivaldi, Firefox

Operating system:


ownCloud log (data/owncloud.log)

This is the important part, I guess

{"reqId":"fsFwhOqJnBqtvKfbTPzq","level":3,"time":"2018-11-21T15:30:16+00:00","remoteAddr":"","user":"<username>","app":"PHP","method":"MOVE","url":"\/remote.php\/webdav\/<my-file>","message":"Allowed memory size of 134217728 bytes exhausted (tried to allocate 992957192 bytes) at \/var\/www\/owncloud\/lib\/composer\/guzzle\/stream\/Guzzle\/Stream\/Stream.php#71"}


The problem was related to PHP memory limit, increasing it solved.

Hello dear,

where did you increase it? I edited the file /var/www/owncloud/config/.user.ini but the issue still happening.

Do I need to restart something or to edit another file?

Thank you.


i think it is either the /var/www/owncloud/.user.ini (i think the /config path in your example is wrong) or the global php.ini (depending on your environment).