[Solved] Issues enabling index.php-less

9.1.x
help

#1

Steps to reproduce
1. Followed instructions from http://askubuntu.com/questions/48362/how-to-enable-mod-rewrite-in-apache and https://doc.owncloud.org/server/latest/admin_manual/configuration_server/index_php_less_urls.html

Expected behaviour
Tell us what should happen
url's should be index.php-less

Actual behaviour
url's are NOT index.php-less

Server configuration
Operating system: Ubuntu 14.04
Web server: ?
Database: ?
PHP version: ?
ownCloud version (see ownCloud admin page): 9.1.2 VMX
Updated from an older ownCloud or fresh install: fresh
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): Changed web route to '/'

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see [] for more info

Sorry couldn't get logs. 
No connection could be made because the target machine actively refused it.
Connection failed.

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

No errors have been found.


#2

Please post:

  • your config.php (remove sensitive values from it)
  • the output of a2enmod in your console
  • the content of your /var/www/owncloud/.htaccess
  • The output of the command ls -la /var/www/owncloud/.htaccess

#3

I don't know how to transfer the files you requested from my server. I'm running inside a virtual machine on VMware Player. I cannot FTP to my server, connection refused. I tried copying the files to my owncloud/data/username/files but they wouldn't show up on server.


#4

Hi,

then you might research how to get this stuff from a Virtual Maschine. From my PoV teaching such basics are out of the scope of this forums.


#5

I've done nothing but research for the past 30 minutes. I listed the things I've already tried. Could you please point me in the right direction?


#6

What about using the Clipboard of the VMWare player and just copy the output?


#7

I wasn't able to copy the log in a text format. I don't have a GUI, it is text only. I installed VMware tools by following a guide on the internet and it is work but there's no option to transfer the contents of the clipboard or files to the host. I got thinking though, VMware does let you take screenshots of the guest os and that's what I did. Here you go.

config.php




config.php
a2enmod
htaccess
htaccess permissions


#8

Hi,

the last screenshot shows your issue. The www-data user has no write permissions to write to the .htaccess file.


#9

What permissions do I need to assign it?


#10

Permissions which allows the www-data to write into that file. The following docs might be a good starting point:


#11

I chmod 777 to root, then chown to www-data, ran occ, then restored permissions and owner and it worked. thanks.