[SOLVED] Market stopped working after upgrade 10.0.9 --> 10.0.10. Something wrong with certificate?


#1

Steps to reproduce

1.Upgrade from 10.0.9 to 10.0.10
2.
3.

Expected behaviour

Market should work

Actual behaviour

Market does not open. I get following error on screen:
No marketplace connection: cURL error 77: error setting certificate verify locations: CAfile: /var/www/owncloud/data/files_external/rootcerts.crt CApath: /etc/ssl/certs

I have checked that there is a rootcerts.crt in that directory and that certificate is not empty

Server configuration

Operating system:
Ubuntu 16.04LTS

Web server:
Apache 2.4.18

Database:
mysql Ver 14.14 Distrib 5.7.23

PHP version:
7.0.32

ownCloud version: (see ownCloud admin page)
10.0.10

Updated from an older ownCloud or fresh install:
10.0.9

Where did you install ownCloud from:
from apt-get repository

Signing status (ownCloud 9.0 and above):

No errors have been found.

The content of config/config.php:

{
“system”: {
“instanceid”: “oc5rl1d2bu5s”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“memcache.local”: “\OC\Memcache\APCu”,
“trusted_domains”: [
REMOVED MY DOMAIN INFO
],
“datadirectory”: “/var/www/owncloud/data”,
“overwrite.cli.url”: “REMOVED MY DOMAIN INFO”,
“dbtype”: “mysql”,
“version”: “10.0.10.4”,
“installed”: true,
“logtimezone”: “Europe/Helsinki”,
“logfile”: “/var/log/owncloud.log”,
“loglevel”: 2,
“log_authfailip”: true,
“mail_smtpmode”: “smtp”,
“mail_smtpauthtype”: “LOGIN”,
“mail_smtpauth”: 1,
“mail_smtphost”: “REMOVED SENSITIVE VALUE”,
“mail_from_address”: “REMOVED SENSITIVE VALUE”,
“mail_domain”: “REMOVED SENSITIVE VALUE”,
“mail_smtpport”: “465”,
“mail_smtpname”: “REMOVED SENSITIVE VALUE”,
“mail_smtppassword”: “REMOVED SENSITIVE VALUE”,
“mail_smtpsecure”: “ssl”,
“theme”: “”,
“maintenance”: false,
“dbname”: “owncloud”,
“dbhost”: “127.0.0.1”,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“check_for_working_htaccess”: true,
“appstoreenabled”: true,
“apps_paths”: [
{
“path”: “/var/www/owncloud/apps”,
“url”: “/apps”,
“writable”: true
}
],
“trashbin_retention_obligation”: “auto”,
“updatechecker”: false,
“htaccess.RewriteBase”: “/”
}
}

List of activated apps:

Enabled:

  • calendar: 1.6.0
  • comments: 0.3.0
  • configreport: 0.1.1
  • dav: 0.4.0
  • federatedfilesharing: 0.3.1
  • federation: 0.1.0
  • files: 1.5.1
  • files_external: 0.7.1
  • files_sharing: 0.11.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • files_videoplayer: 0.9.8
  • firstrunwizard: 1.1
  • gallery: 16.1.0
  • market: 0.2.5
  • notifications: 0.3.5
  • provisioning_api: 0.5.0
  • systemtags: 0.3.0
  • templateeditor: 0.3.1
  • twofactor_totp: 0.4.4
  • updatenotification: 0.2.1
    Disabled:
  • encryption
  • external
  • user_external

Are you using external storage, if yes which one: local/smb/sftp/…
NO

Are you using encryption: yes/no
NO

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…
NO

ownCloud log (data/owncloud.log)

{“reqId”:“JpEcBkAuT8jvkxrB2QrF”,“level”:3,“time”:“2018-09-29T21:00:04+03:00”,“remoteAddr”:"",“user”:"–",“app”:“core”,“method”:"–",“url”:"–",“message”:“Error while running background job (class: OCA\Market\CheckUpdateBackgroundJob, arguments: ): {“Exception”:“OCP\\App\\AppManagerException”,“Message”:“No marketplace connection: cURL error 77: error setting certificate verify locations:\n CAfile: \/var\/www\/owncloud\/data\/files_external\/rootcerts.crt\n CApath: \/etc\/ssl\/certs”,“Code”:0,“Trace”:”#0 \/var\/www\/owncloud\/apps\/market\/lib\/MarketService.php(512): OCA\\Market\\MarketService->httpGet(‘https:\/\/marketp…’)\n#1 \/var\/www\/owncloud\/apps\/market\/lib\/MarketService.php(393): OCA\\Market\\MarketService->queryData(‘apps_10.0.10’, ‘\/api\/v1\/platfor…’)\n#2 \/var\/www\/owncloud\/apps\/market\/lib\/MarketService.php(219): OCA\\Market\\MarketService->getApps()\n#3 \/var\/www\/owncloud\/apps\/market\/lib\/MarketService.php(199): OCA\\Market\\MarketService->getAppInfo(‘calendar’)\n#4 \/var\/www\/owncloud\/apps\/market\/lib\/MarketService.php(322): OCA\\Market\\MarketService->getAvailableUpdateVersion(‘calendar’)\n#5 \/var\/www\/owncloud\/apps\/market\/lib\/CheckUpdateBackgroundJob.php(85): OCA\\Market\\MarketService->getUpdates()\n#6 \/var\/www\/owncloud\/lib\/private\/BackgroundJob\/Job.php(57): OCA\\Market\\CheckUpdateBackgroundJob->run(NULL)\n#7 \/var\/www\/owncloud\/lib\/private\/BackgroundJob\/TimedJob.php(53): OC\\BackgroundJob\\Job->execute(Object(OC\\BackgroundJob\\JobList), Object(OC\\Log))\n#8 \/var\/www\/owncloud\/cron.php(120): OC\\BackgroundJob\\TimedJob->execute(Object(OC\\BackgroundJob\\JobList), Object(OC\\Log))\n#9 {main}",“File”:"\/var\/www\/owncloud\/apps\/market\/lib\/MarketService.php",“Line”:475}"}

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

Hey,

i did the following search with the search function on the upper right of this forums:

https://central.owncloud.org/search?q=%22error%20setting%20certificate%20verify%20locations%22

and found two existing threads including the same message. Maybe you can find some hints on this issue within those?


#3

SOLVED!

I deleted the file /var/www/owncloud/data/files_external/rootcerts.crt , restarted apache and now the market is working again!