Solved - Missing files when migrating from from to

Just migrate (Owncloud on 1and1) from to giving missing files integrity verification.
For “ocm-provider/index.php” i have no such directory but i have “ocs-provider/index.php”

Migration executed from the owncloud admin web interface

Sorry not very fluent in english
Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix


Raw output

[core] => Array
[] => Array
[expected] => 4886c8d58c46aba30f8577efaa04719ff315cb72d68d27374c3649ca9578baef18da9cd7165579c4425a0094d5359804c49600235cccd51737a2c9db613d69b5
[current] =>

            [ocm-provider/index.php] => Array
                    [expected] => 0c640fe229b0d25f3c291e368ad5a337df4c84e97d1ff750f6db6fa548d64f7caf78dd6b9ad23aa68fccdb747a380f399250a5cf1535b8029f09ea02d8c777ad
                    [current] => 

            [updater/] => Array
                    [expected] => 30634ecf94beb635907baa4c1f9a144080890f172db28ce09515b5f9e5415255bbfab51dfdcecdf5eb3a7eaf97b558463758a5222d5eca696b2f8eb50ba28451
                    [current] => 




Hi, where is solution ? I havent found after sign up. Could you please write, how can I fix the problem with missing file? I see, there is no more ocm directory, only “ocs”. Is that OK?
Thank you in advance! Robert

I have :slight_smile:

  • downloaded the last release from
  • extract the files
  • copy the missing files to my installed owncloud



Hi, I had exactly the same issue as LuptakRobert, described above. I took the action suggested by genealogist. I then rebooted my server, but the warning notification remains. I’m only an occasional admin as my system is a home server that I use for my personal computers and devices. Can somebody point me towards clearing the notification which I assume is a hang-over from the installation?

Ah - found it. In case anybody else is as daft as me, simply click on the ‘rescan’ link in the extended message displayed when you click on the orange banner message. It’s in the documentation!


In my case the ocm-provider folder was really missing. Here is how I solved it with SSH access:

$ cd myownclouddir
$ mkdir ocm-provider
$ cd ocm-provider
$ curl -o index.php

This creates the ocm-provider dir and then downloads the index.php file from the current Github branch.


Make sure to give that folder the right ownership and permissions. As the folder will have the ownership of your session.

1 Like

thanks! solved my same problem