[SOLVED] Move of data directory failed: Service unavailable


#1

Hi all,

I just moved my data directory using the manual way described in the documentation. I amended the path in the config.php and in the database oc_storages. In the WebGUI all files are shown, but trying to access a file I receive "service unavailable". I checked permissions. Everthing seems to be fine, as I used rsync for moving directory. I just moved the directory a few levels higher, out of the web server root. In the owncloud-database I found the oc_accounts, which still show the old path. Do I have to amend this, too, or can I update this with any occ command? Because it's not described in the documentation. When I just move back the data directory to the old location without correcting the config-php and oc_storages files can be accessed again. Any idea?

My System:
Owncloud 10.0.2.1
Own Server with OpenSuse Leap 42.1
PHP 5.6
Server version: Apache/2.4.16 (Linux/SUSE)

Thanks and kind regards,

Joshua


#2

check the oc_accounts table, might need to adjust paths there as well...

This was missing from the docs as it's new in 10.0, sorry. See https://github.com/owncloud/documentation/issues/3194


#3

Hello,

thanks for the confirmation. With amending oc_accounts and oc_storages everything worked fine. Not to forget correct path in config.php.

Joshua