SOLVED: OC Client connection fails with 403 Forbidden

Firstly, I’m not as good at server stuff as the rest of you so please be patient.
I have OC 10.5.0 (stable) on a shared Linux server.
There are two PCs connected: PC1 (Win7) and PC2 (Win10)
Both run OC Client 2.7.6 (build 3261)

Some time ago I had a problem cause by the Hosting provider blocking access
Something similar happened again last night.
I spoke to the Provider today and they confirmed that another rule was blocking me and they removed it.

So now, the connection from PC2 (on the same network and OC account as PC1) works fine.
But all attempts to connect to the OC server from PC1 now gives

Error: Server relied 403 Forbidden to owncloud forbidden to get status.php

The web interface on PC1 works fine.

I deleted the connection in the Client on PC1 and tried to add it again.
I now get the error shown below under “Actual behaviour”.
I have put a link to the owncloud.log file below .

Any suggestions please?
If I need to go back to the hosting provider please can you suggest some suitable words for what to ask?
Thank you for reading this far and for any assistance you can provide.

Expected behaviour

OC client should connect to the OC server

Actual behaviour

The client is unable to connect. The server returns

Error: Server replied “403 Forbidden” to “myDomain.com/owncloud/remote/php/webdav/

Steps to reproduce

  1. Open Client
  2. Enter correct server URL and account details

Server configuration

Operating system:cPanel/Linux

Web server:

Database:

PHP version:

ownCloud version: 10.5.0

Storage backend (external storage):

Client configuration

Client version:
2.7.6
Operating system:
Win7

OS language:

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client:

Logs

Template for output < 10 lines

  1. Client logfile: Output of owncloud --logwindow or owncloud --logfile log.txt

  2. Web server error log:

  3. Server logfile: ownCloud log (data/owncloud.log):
    The owncloud.log file is here. I have changed the first two octets of the IP address.
    http://www.zen17229.zen.co.uk/owncloudLogFolder/owncloud.log

Since posting the above I noticed other problems with PC1.
I found a restore point at 1803 last night.
This was created when the OC client updated from 2.7.5 to 2.7.6.
I restored the PC to that point.
My non-OC problems were immediately resolved and the OC client decided to work again (v2.7.5).

To my simple mind this points to the upgrade to OC client 2.7.6.

Incidentally, I don’t like the way we are not given the choice to upgrade the client or not.
When starting a notebook PC in front of a customer it is quite annoying to find a box demanding that I upgrade now.

According to your observations, 2.7.5 works, and 2.7.6 doesn’t work?

Could you create a test account, verify the issue is also reproducible with the test account, then send to apps-<at>-owncloud.com?

Thanks for responding.
The answer to your question is yes, that’s my assumption.

I need to check I have understood your request:

  1. When you say “Create a test account” do you mean create a new user on the OC server?

  2. Unless I am mistaken, I would only be able to reproduce the issue by upgrading the OC Client to 2.7.6. If that was the cause of the problem on PC1 then I am very reluctant to do that as it also coincided (or caused) issues with other applications which were very disruptive.