[Solved] Owncloud desktop client unmet dependencies issue

linux_basics
client
help

#1

I've been using the nightly version of the Owncloud desktop client for a while on Elementary OS (built on Ubuntu 16.04), but when switching back to stable and installing owncloud-client I got the following errors:

$ sudo apt install owncloud-client
[sudo] password for peteruithoven: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 owncloud-client : Depends: libowncloudsync0 (= 2.2.4-9.1) but it is not going to be installed
               Depends: libqt5core5a (>= 5.6.0~beta) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
               Depends: libqt5keychain1 but it is not going to be installed
               Depends: libqt5webkit5 (>= 5.6.0~rc) but it is not going to be installed
               Depends: owncloud-client-l10n but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I then tried explicitly installing libowncloudsync0, but that also didn't work:

$ sudo apt install libowncloudsync0
[sudo] password for peteruithoven: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libowncloudsync0 : Depends: libqt5core5a (>= 5.6.0~beta) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
                Depends: libqt5keychain1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I'm pretty sure nothing is wrong with the owncloud-client, it's probably something I'm doing wrong.

Normally I would try ppa-purge, but owncloud doesn't use a ppa.
I tried following tips from: http://askubuntu.com/questions/223237/unable-to-correct-problems-you-have-held-broken-packages#223267
But dpkg --get-selections | grep hold gives 0 results, I don't have aptitude, running autoremove doesn't help.

I've also tried switching back to the nightly (changing /etc/apt/sources.list.d/owncloud-client.list, running apt update), and just to be sure running apt dist-upgrade and apt autoremove. But when then installing owncloud-client I get a similar response.

I also tried Synaptic Package Manager's Edit > Fix Broken Packages. This ran without issues, showing Successfully fixed dependency problems, but not fixing my issue.


#2

I'm an idiot, I was adding the source for Ubuntu 16.10, instead of 16.04 (LTS) where Elementary OS is build on.
When following the instructions for 16.04 everything went fine.