[SOLVED] Password Policy-App: licence key in config.php


#1

Hi there,

I just upgraded to oc 10.0.9 and tried to install the PasswordPolicy-app 2.0.0 from the market, as this should be now free for community edition, too. But during installation I get a warning “Please insert a licence key to config.php”. And the app is not installed. The link in the app description https://doc.owncloud.com/server/latest/admin_manual/configuration/server/security/password-policy.html leads to an 404-error.
Can anybody advise how to install the PassowrdPolicy-app into an existing oc 10.0.9 server with already configured users?

Thanks and kind regards,

Joshua


#2

Hi Joshua,

Thanks for reporting! Unfortunately the doc link seems to have changed. Find the correct one here: https://doc.owncloud.com/server/latest/admin_manual/configuration/server/security/password_policy.html

Regarding your issue with license key: This is not expected to happen and it doesn’t when I try on my installation. Maybe you played around with enterprise trial and have the enterprise_key app installed? If so, you could try to disable it. If that doesn’t help, please file an issue on GitHub including a Config report.

Hope this helps!


#3

The issue has been reproduced and will be investigated. See here https://github.com/owncloud/password_policy/issues/74.


#4

Hi,

did I understand right that as a workaround I can manually download the app from the marketplace and install it with this command:

sudo -u www-data ./occ market:install -l apps/password_policy-2.0.0.tar.gz

Kind regards,
Joshua


#5

Yes, correct, that’s the workaround for now. The issue is with the “Market app”. It’s already fixed and will need a new release of said app (https://github.com/owncloud/market/issues/360). Please close if your issue is solved.


#6

Hi,

I downloaded the file from the marketplace and moved it to the owncloud/apps folder. Changed the owner settings to my www-user and executed the command given above:

owncloud # sudo -u wwwrun ./occ market:install -l apps/password_policy-2.0.0.tar.gz 
The process control (PCNTL) extensions are required in case you want to interrupt long running commands - see http://php.net/manual/en/book.pcntl.php
password_policy: Installing new app from apps/password_policy-2.0.0.tar.gz
password_policy: App installed.

Afterwards I found the app under Settings/Apps/Deaktivated Apps and activated the app. The password policies can be set under Settings/Administration/Security.

Everything fine. Thanks a lot.