[SOLVED] Redirected to the root when they click on the "+" menu

10
help

#1

Hi there.

I installed an ownCloud server for my client since 3-4 months now.
There is about 44 people using it in production.

I have some troubles, one in particular.
About 10 on 44 people have this issue and it’s really weird. Some people have it sometimes, some never, some every day…

Steps to reproduce

  1. Create a folder structure with an account (admin)
  2. Share some folders with read/write rights to other accounts (users)
  3. Using the web interface, a user clicks on the “+” icon to create a new subfolder on the shared folder. He has proper rights to do this.

Expected behaviour

A submenu should open and he should be able to create a new subfolder

Actual behaviour

He is redirected to the site index. No error message. Nothing related to this in logs.

Server configuration

Operating system: Debian 9.7

Web server: Apache 2.4.25

Database: MariaDB 15.1 Distrib 10.1.37

PHP version: 7.1.26-1

ownCloud version: (see ownCloud admin page) 10.0.10 (stable)

Updated from an older ownCloud or fresh install: Fresh install (installed at 10.0.x then updated once)

Where did you install ownCloud from: Tar.bz2 (recommended method)

Signing status (ownCloud 9.0 and above): No signing

The content of config/config.php:

{
    "basic": {
        "license key": "***REMOVED SENSITIVE VALUE***",
        "date": "Wed, 13 Feb 2019 10:57:21 +0000",
        "ownCloud version": "10.0.10.4",
        "ownCloud version string": "10.0.10",
        "ownCloud edition": "Community",
        "server OS": "Linux",
        "server OS version": "Linux foo.center 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u6 (2018-10-08) x86_64",
        "server SAPI": "apache2handler",
        "webserver version": "Apache",
        "hostname": "***REMOVED SENSITIVE VALUE***r",
        "logged-in user": "***REMOVED SENSITIVE VALUE***"
    },
    "stats": {
        "users": {
            "Database": {
                "count": 44,
                "seen": 44,
                "logged in (30 days)": 42
            }
        },
        "groups": {
            "OC\\Group\\Database": 7
        }
    },
    "config": {
        "instanceid": "oc3lygj8n2wf",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "***REMOVED SENSITIVE VALUE***"
        ],
        "datadirectory": "\/var\/www\/owncloud\/data",
        "overwrite.cli.url": "***REMOVED SENSITIVE VALUE***",
        "dbtype": "mysql",
        "version": "10.0.10.4",
        "dbname": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "localhost",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "logtimezone": "Europe\/Paris",
        "installed": true,
        "default_language": "fr_FR",
        "defaultapp": "files",
        "allow_user_to_change_display_name": false,
        "maintenance": false,
        "enable_certificate_management": false,
        "redis": {
            "host": "localhost",
            "port": 6379,
            "timeout": 0,
            "password": "***REMOVED SENSITIVE VALUE***",
            "dbindex": 0
        },
        "filelocking.enabled": true,
        "cache_path": "",
        "memcache.local": "\\OC\\Memcache\\Redis",
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "preview_libreoffice_path": "\/usr\/bin\/libreoffice",
        "enabledPreviewProviders": [
            "OC\\Preview\\PNG",
            "OC\\Preview\\JPEG",
            "OC\\Preview\\GIF",
            "OC\\Preview\\BMP",
            "OC\\Preview\\XBitmap",
            "OC\\Preview\\MP3",
            "OC\\Preview\\TXT",
            "OC\\Preview\\MarkDown",
            "OC\\Preview\\PDF",
            "OC\\Preview\\OpenDocument",
            "OC\\Preview\\MSOffice2003",
            "OC\\Preview\\MSOffice2007",
            "OC\\Preview\\MSOfficeDoc",
            "OC\\Preview\\Photoshop",
            "OC\\Preview\\Illustrator"
        ],
        "integrity.ignore.missing.app.signature": [
            "customtheme"
        ],
        "apps_paths": [
            {
                "path": "\/var\/www\/owncloud\/apps",
                "url": "\/apps",
                "writable": true
            },
            {
                "path": "\/var\/www\/owncloud\/apps-external",
                "url": "\/apps-external",
                "writable": true
            }
        ],
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpmode": "smtp",
        "mail_smtpsecure": "tls",
        "mail_smtpauthtype": "LOGIN",
        "mail_smtpauth": 1,
        "mail_smtpport": "587",
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
        "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
        "loglevel": 2
    },
    "integritychecker": {
        "passing": true,
        "enabled": true,
        "result": []
    },
    "core": {
        "backgroundjobs_mode": "cron",
        "installedat": "1532898365.6942",
        "lastcron": "1550054703",
        "lastupdateResult": "[]",
        "lastupdatedat": "1550055175",
        "public_files": "files_sharing\/public.php",
        "public_webdav": "dav\/appinfo\/v1\/publicwebdav.php",
        "shareapi_allow_group_sharing": "yes",
        "shareapi_allow_links": "yes",
        "shareapi_allow_mail_notification": "yes",
        "shareapi_allow_public_notification": "yes",
        "shareapi_allow_resharing": "yes",
        "shareapi_auto_accept_share": "yes",
        "shareapi_default_expire_date": "no",
        "shareapi_default_permissions": "1",
        "shareapi_enabled": "yes",
        "shareapi_exclude_groups": "yes",
        "shareapi_exclude_groups_list": "[\"clubs\",\"check\",\"prob\",\"medias\"]",
        "umgmt_send_email": "false",
        "umgmt_set_password": "***REMOVED SENSITIVE VALUE***",
        "umgmt_show_email": "true",
        "umgmt_show_is_enabled": "false",
        "umgmt_show_last_login": "true",
        "umgmt_show_storage_location": "false",
        "vendor": "owncloud"
    },
}

List of activated apps:

Enabled:
  - activity: 2.4.1
  - comments: 0.3.0
  - configreport: 0.1.1
  - dav: 0.4.0
  - federatedfilesharing: 0.3.1
  - federation: 0.1.0
  - files: 1.5.1
  - files_antivirus: 0.14.0
  - files_clipboard: 0.7.1
  - files_external: 0.7.1
  - files_pdfviewer: 0.10.0
  - files_sharing: 0.11.0
  - files_trashbin: 0.9.1
  - files_versions: 1.3.0
  - files_videoplayer: 0.9.8
  - firstrunwizard: 1.1
  - gallery: 16.1.1
  - customtheme: 1.0.0
  - market: 0.3.0
  - notifications: 0.3.5
  - provisioning_api: 0.5.0
  - systemtags: 0.3.0
  - updatenotification: 0.2.1
Disabled:
  - encryption
  - external
  - user_external

Are you using external storage, if yes which one: no

Are you using encryption: no

Are you using an external user-backend, if yes which one: none

Client configuration

Browser: Firefox, Chrome, Safari…

Operating system: Windows, OS X…


#2

Up

As the issue is hard to describe and I have no logs for it (I think it’s frontend related), here is a vidéo of the bug from a user. Precisions : I tested it myself with TeamViewer and it happends in every browser… With/withouyt antivirus, a browser freshly reinstalled… some have it on mac, others on windows.


As you can see, instead of having a “folder” and “load” icon, the user is redirected to the root of the server. The user is using this folder created by another, and he has every possible rights on it : share/modify/create/delete…

I can’t believe I am the only one that have this issue… :roll_eyes:

Edit 2
I cannot reproduce this bug on my own computer but many of my users are facing it. What I can say is that sometimes, a click at some folder on the breadcrumb redirect me to the root too. I think it is related to this console deprecation warn :

js.js?v=cbcf64e3805767a421c2aa0274eca2cc:2296 Deprecation warning: tipsy is deprecated. Use tooltip instead.

Any idea? Any help would be really appreciated! :persevere:


#3

can you set the log level to debug and see if anything comes up?

I suspect a missing module or a web server misconfiguration.

How did you setup ownCloud?


#4

Hi.

I already tried to set up log level debug and I cannot see anything.
I installed OwnCloud using tar.bz2 and following the official documentation instructions.

If a module were missing I would see it right?


#5

Which browser are your clients using? Looks like some javascript code is not getting executed …

Please have a look at the console while pressing the button - due to the page reload the console will be clear pretty quick. Some browers (e.g. Chrome) have an option to preserve the log …

Good luck


#6

@DeepDiver1975 thank you.
My client who is facing this bug everytime has the same browsers and versions as me

  • Firefox 65.0
  • Chrome 72.0.3626.81
    Both have the same behavior : same bug. With the same config, I have no issue.
    But I am on Ubuntu 18.04 and he is on Windows 7.

I found the chekbox to preserve logs on Chrome, I’ll try to check it on his Chrome when the redirection happends. I let you know.


#7

@DeepDiver1975

I just re-tried with persistent logs on Chrome on my client desktop, and there is nothing more than usual.
Here is the complete session in logs, the “navigated to” is when he is redirected unexpectedly

JQMIGRATE: Migrate is installed, version 1.4.0
12VM33 js.js:2296 Deprecation warning: tipsy is deprecated. Use tooltip instead.
jQuery.fn.tipsy @ VM33 js.js:2296
18VM33 js.js:2296 Deprecation warning: tipsy is deprecated. Use tooltip instead.
jQuery.fn.tipsy @ VM33 js.js:2296
markFileAsShared @ VM63 share.js:309
_updateFileActionIcon @ VM141 share.js:237
(anonymous) @ VM141 share.js:149
.each..forEach @ VM20 underscore.js:153
(anonymous) @ VM141 share.js:130
dispatch @ VM17 jquery.min.js:3
r.handle @ VM17 jquery.min.js:3
trigger @ VM17 jquery.min.js:3
a.event.trigger @ VM18 jquery-migrate.min.js:2
(anonymous) @ VM17 jquery.min.js:3
each @ VM17 jquery.min.js:2
each @ VM17 jquery.min.js:2
trigger @ VM17 jquery.min.js:3
_nextPage @ VM106 filelist.js:987
setFiles @ VM106 filelist.js:1039
reloadCallback @ VM106 filelist.js:1676
(anonymous) @ VM17 jquery.min.js:2
j @ VM17 jquery.min.js:2
fireWith @ VM17 jquery.min.js:2
e.(anonymous function) @ VM17 jquery.min.js:2
(anonymous) @ VM74 client.js:479
Promise.then (async)
getFolderContents @ VM74 client.js:472
reload @ VM106 filelist.js:1595
changeDirectory @ VM106 filelist.js:1454
(anonymous) @ VM115 fileactions.js:634
_onClickFile @ VM106 filelist.js:665
dispatch @ VM17 jquery.min.js:3
r.handle @ VM17 jquery.min.js:3
Navigated to xxxx/index.php/apps/files/
jquery-migrate.min.js?v=cbcf64e3805767a421c2aa0274eca2cc:2 JQMIGRATE: Migrate is installed, version 1.4.0

I don’t know what to do … :face_with_raised_eyebrow:


#8

Hi.

I finally found what happend.
It was just a height issue on my logo-icon class… :sweat_smile:
I coded a custom theme, and I let a very big height for my logo-icon class. So when the logo is specifically on top of the “+” button, the logo link replaces it.

I found myself really dumb. So there is nothing related to ownCloud. It was pretty tricky to debug because the way to trigger the bug depends of the screen resolution.

I close this ticket.

@DeepDiver1975 @dmitry thank you for your time :slightly_smiling_face: