[Solved] What file I should edit to change the place of a SSL certificat?


#1

Hello,

What file I should edit to change the place of a SSL certificat ? I have 'lets encrypt' installed now but the certificat I have create by my Control Panel doesn't remplace the one create in installation of Owncloud. Sure it's a ugly selft-signed :blush:

Thanks for your help


#2

ownCloud is just a web application written in PHP and doesn't handle any SSL certificates. This is your webservers job.

Try to contact the support of your hoster or read the manual of your control panel how to configure and deploy SSL certificates for your environment.


#3

Hi @user67,

The location of Let's Encrypt's certificates and other files are slightly different depending on your OS. For example, I use FreeBSD, so my files are located in /usr/local/etc/letsencrypt/. My understanding is that most Linux distros put them in /etc/letsencrypt/ (provided you're control panel uses the official client as the back-end). Different clients put files in different locations, so you'd have to check your control panel manual.

However you should first check to see if your question has already been answered here:

That's where I go for my Let's Encrypt answers. They've been asked similar questions to yours many times :slight_smile:

Failing that, @kljhlkhglklfgh is correct, you should contact your hoster and read your control panel manual for more information.


#4

Hello,

In fact the letsencrypt files are in this folder:
ls -lha /home/admin/conf/web/
-rw-r--r-- 1 root root 147 Mar 9 10:28 nginx.cloud.mydomain.com.conf_letsencrypt
-rw-r----- 1 root root 1.7K Mar 9 11:26 ssl.cloud.mydomain.com.ca
-rw-r----- 1 root root 2.2K Mar 9 11:26 ssl.cloud.mydomain.com.crt
-rw-r----- 1 root root 3.2K Mar 9 11:26 ssl.cloud.mydomain.com.key
-rw-r----- 1 root root 3.8K Mar 9 11:26 ssl.cloud.mydomain.com.pem

What can I do with this for declarate the SSL connection?

Thx


#5

Hi,

i think you get quite a few pointers where to get help for such non-ownCloud related stuff like a SSL configuration. The forum here is also used for giving support for ownCloud and people can't know how to configure such stuff on your environment, especially not when using stuff like the control panel of your hoster.


#6

Hi,

I have unchecked the box for the SSL certificat, restart the server, and check again the Let's encrypt case and the SSL works now.

Not at all a Owncloud issu, in fact ^^