SQLSTATE[28000][1045] Access denied for user 'root'@'localhost' (using password:YES)

reported_bug
9.1.x
help

#1

Hi, i installed OC 9.1.0, 9.0.3 and 8.2.6 and got this error during first login to create the admin user.
For this i took the user root and did not create an own database, because owncloud would to this on his own.
I did this several times and got every time this error. I also be able to logon mysql with that user. Password works and i am able to logon.
My hardware is an Raspberry Pi 3.
Do you have any ideas to help.
Thank you.
regards
Wolfgang


Failed to connect to the database: Access denied for user 'root'@'localhost' in /var/www/owncloud/lib/private/DB/Connection.php
#2

Hi,

there are quite a lot resources available when searching for that message like:

The page available at https://dev.mysql.com/support/ shows also some resources where to get help for mysql issues.


#3

Hi,
yes i read many of them. But most describing issues directly using mysql. All tests in my mysql give no negative feedbacks. Only usage from the owncloud page shows that message.
regards


#4

Still its the best to ask at a mysql support channel as they knows better how to debug something like this


#5

Yes, another option. But could you say that this is no issue for owncloud? I only want to use owncloud.


#6

After updating from oc 9.0.4 to 9.1.0 I ran into issue https://github.com/owncloud/core/issues/25582

I wanted to go back to 9.0.x to avoid the issue. I use a cubieboard 3 with armbian to run ownlcoud. I am fairly new to linux and I am rather unfamiliar with sql and php. So I used a clean armbian image and set the repository to:
https://download.owncloud.org/download/repositories/9.0/owncloud/
I ran
apt-get install mysql-server ( in the process set root-user and root password)
apt-get install owncloud
call .../owncloud to run install-wizard and I ran into the same problem you do. I got same SQL-Error
login to my sql as root-user with root-password worked for me as it did for Wolfgang

Finally I read about the workaround for issue 25582 (keep user quota unlimited) and gave oc 9.1.0 another try.

Get a clean armbian image, set repository to:
https://download.owncloud.org/download/repositories/stable/owncloud/
apt-get install mysql-server (setting root-user and root-password)
apt-get install owncloud
call .../owncloud to run install wizard and everything worked as expected.

I support Wolfgang's opinion that under some condition the install wizard does not work as intended.

It is beyond my abilities to figure out how the two wizards differ and why on installations a wizard 9.1.0 runs as expected and the one from 9.0.4 does not. The only difference I see ist the source of the oc installation.

Wolfgang, how did you install the different versions of oc.

Hope my description helps to locate the problem.

Regards
Jörg


#7

Hello Jörg,
thanks for your answer. I didn't check if your hint will also help me.
I had another idea, and that works, twice with 8.2.6 and also with 9.1.
In front of starting ownloud i disable password with phpmyadmin for the myql user root.
The installation works fine now.
After it has done it's work i set the password again.
Because i do that without internet connection, this should not be a risk.

I think there must be an issue in the asistent. May be an timeout, or something like that.

For your question: How i install several versions. see it here.


#8

Maybe just report a bug to https://github.com/owncloud/core/issues if you think this is a issue in oC


#9

Ref:


#10

It appears that with recent mariadb, you may log in as root (mysql user) with the client started as root (linux user) but not with the client started as a non-root (linux user). This is documented here:

So in that case, you may log in mysql without problems, but the sudo -u www-data makes owncloud unable to log in as root. You need to create a user with sufficient privileges before.