I am sure this is an apache2 issue. I have spent all afternoon trying various ways to make this work and have run into a dead end. I must ask for help :slight_smile:.
I have been running am OwnCloud server on a Raspberry pi now for several years with a signed certificate.
The time has come for me to renew it and I am having problem with accessing pki-validation text file on the server located in /var/www/ssls/.well-known/pki-validation folder.

I have read the document on the Let’s Encrypt process. It looks very similar with just a few minor text differences. I have copied and added the following to the 000-default.conf making the path/file name changes.

Alias /.well-known/pki-validation/ /var/www/ssls/.well-known/pki-validation/
<Directory “/var/www/ssls/.well-known/pki-validation/”>
Options None
AllowOverride None
ForceType text/plain
RedirectMatch 404 “^(?!/.well-known/pki-validation/[\w-]{43}$)”

After restarting the apache2 server I still am not able to retrieve the necessary validation text file.
Am I missing something? What else do I need to do?


I wonder why you are trying with ssls·com when there is
For the latter there is a vast bunch of tutorials and forum entries.

1 Like