Status.php calling OC::handleRequest()

9.1.x
help

#1

Hi,
after an upgrade from a rather old version to ownCloud 9.1 I cannot access the status.php site. When I try to do so, I get redirected to the login page or the default page if I'm logged in. I traced this back to status.php somehow calling OC::handleRequest() which does the default request handling. I could not find out however, where the code is called. status.php includes lib/base.php where the OC class is defined and instantiated but it does not call handleRequest() on it, this only happens in index.php.
I inserted a log of a php debug_trackeback, but this only shows one entry, the handleRequest method:

{"reqId":"V\/tjukXfc97Ye9C5jvEh","remoteAddr":"<ip>","app":"no app in context","message":"[{\"file\":\"\\\/var\\\/www\\\/owncloud\\\/index.php\",\"line\":39,\"function\":\"handleRequest\",\"class\":\"OC\",\"type\":\"::\",\"args\":[]}]","level":2,"time":"2016-11-09T15:38:19+00:00","method":"GET","url":"\/status.php","user":"--"}

Do you have an idea what could be going wrong or how I can trace the problem further?

Server configuration
Operating system: Debian Jessie
Web server: nginx 1.6.2
Database: mariadb 10.0.27
PHP version: 5.6.27
ownCloud version (see ownCloud admin page): 9.1.1
Updated from an older ownCloud or fresh install: 6.0.5 (via all other major releases)
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): none

Integrity status for oC9+

No errors have been found.

#2

Hi,

have you updated your nginx config to the one for oC9+ provided at doc.owncloud.org ?


#3

Yes, with the migration I also switched from apache to nginx. I just double checked and apart from removing comments, substituting parameters such as server name and enabling IPv6 the configurations are the same.


#4

Hi,

the nginx config provided there is known to work on a wide range of systems and distros out there. If you see such issues with the status.php you might want to setup a fresh Debian Jessie (have the same setup running here) and compare that working setup with your not working.


#5

Thanks, you pointed me in the right direction. After setting up a debian container with ownCloud I compared the configurations: I had a typo in the location regex, there was a slash where a pipe symbol should've been.