Stop auto update on Debian 10

Dear owncloud community,

I finalise my 2de install of owncloud (cause i can’t used the 1st one). This install is on Debian 10.

I try to block auto update following this link, but as I installed it from deb package and offcial repository, i can’t fin the hiden folder/file “$HOME/.local/share/data/ownCloud/owncloud.cfg”. Is there an other way to block auto update? I don’t find any option on web interface to do that.

Best regards,

You’re posting in the server category, but your link is pointing to an ancient version of the desktop client docs.
What did you install where and how?

This sounds like you installed the server.

This is the desktop sync client configuration file, I don’t think this is applicable to you.

I guess you installed the owncloud-files package?

You’ll want to manually update from now on. So you should turn of package updates for this package.

There is a section in the server docs about turning off automatic updates for this package.
I’ll link you straight to the section detailing it with the apt command as you’re running Debian:

You can also disable the update checker inside ownCloud:

But then you’ll have to completely keep your server up to date manually.

1 Like

What is the official repo in your case? Debian’s or ownCloud’s ?
Unfortunately they are not the same. We need somebody with Debian packaging skills to keep them both in sync.

The hidden folder/file should be $HOME/.config/ownCloud/owncloud.cfg

1 Like