Stuck in Maintenance mode ... again

hosting

#1

Hi All,
yes I used the search… I found many posts telling to use the search. But I still did not find a solution for my problem.
I run Owncloud on a shared server at a provider, so I cannot do any "sudo"s or other Unix commands. I am stuck with the Web-Frontend of owncloud and ftp.

I manually changed config.php with maintenance=false, but this does not help.

Update status.php says:

installed true
maintenance true
needsDbUpgrade true
version "10.0.9.5"
versionstring "10.0.9"
edition "Community"
productname "ownCloud"

I tried domain.com/updater/index.php and it asked for the updatersecret from config.php but it says “invalid password” (even ifI use paste+copy!!!) Why?

Do you have any ideas? I read about disabling apps. How do I do that with ftp?

Regards
Gabriel


#2

If you don’t have any option to manipulate the database, then I’m afraid you’re out of luck.

I think, your hosting isn’t appropriate for running owncloud.

[EDIT] At least one question remains: How did you install owncloud?


#3

Hey, I can access the db via phpadmin frontend. does this work?

I installed owncloud by copying the php files and just start install.php or something. it was a while ago.


#4

Yes, you didn’t mention this. Please use the search function, you’ll find multiple post on how this can be done.

But maybe, your problem is something different.


#5

I disabled the apps. I still cannot access the updater, because the updater.secret is wrong. But I copy+paste it from config.php. What could cause this? Can I manually change the update.secret in the config.php`?


#6

To be honest: I’ve no clue! I never had to deal with update.secret You must have done something terribly wrong.