Sync reproduces more than expected/wanted

help

#1

Hi,

I'm having the following problem and I'm not sure whether I'm doing it wrong and just overlooking a setting somewhere or some kind of workaround is necessary or it's just impossible. Detailled description see at the end.

Steps to reproduce
1. Have a file collection in a directory structure on oc server
2. Setting up a sync of a particular subfolder of that structure in a particular directory on windows client

Expected behaviour
Just the files inside the designated server folder should be synced into the designated local windows folder

Actual behaviour
The particular server directory structure leading to the designated server directory starting from / is reproduced inside the local client target folder and all files "along" the path are co-synced. Subdirectories "sideways" are not (at least that's expected).

Client configuration
Client version: 2.3.1 (build 6824)
Client operating system: W10Ent1607 14393.447

Server configuration
Operating system: Gentoo (@provider, unknown version)
Web server: apache 2.4 (@provider, modified)
Database: mySQL 5.6.19
PHP version: 7.0.6
ownCloud version (see ownCloud admin page): 9.0.9
Updated from an older ownCloud or fresh install: updated

Detailled description
In my OC there's roughly the following structure:

/Name
    /Subfolder1OfName
    /Subfolder2OfName
    file1InName.xls
    file2InName.xls
    file3InName.doc
/Office
    /Development
    /Mindmaps
    /Stuff
        /ANT
            File1inANT.txt
            File2inANT.txt
        /Roboform
        File1inStuff.txt
        File2inStuff.doc
        File3inStuff.doc
        File4inStuff.ppt
    /WWW
/Temp
    file1inTemp.txt
    file2inTemp.txt
    file3inTemp.txt
file1.txt
file2.txt

The "/Office" branch in its entirety in structure and content is synchronized with several clients on a W10 desktop, some W10 and Linux laptops and an Android device. Works fine, everything ok. Now I was intending to get only those two standalone files inside ANT/ into a particular directory on another laptop. So I set up a client on that laptop and during configuration I navigated to ANT and activated the checkbox right there and only there. The black squares in the checkboxes on the higher levels appeared, indicating the path structure leading to the desired directory.

Next step, I declared the local directory to be synced with it: I chose and defined …
C:\Users\username\Desktop\tmp\ANT\
… to be it, concluded the installation procedure and let the sync start. The intended plan didn't happen. Instead:

a) the complete structure starting with /Office/ was reproduced starting inside Desktop\tmp\ANT\ so I ended up with a local tree C:\Users\username\Desktop\tmp\ANT\Office\Stuff\ANT\ containing the two files AND

b) every single file "next to" the directories along the path was synced inside the newly generated structure: I found file1.txt and file2.txt inside C:\Users\username\Desktop\tmp\ANT and File1... to File5inStuff.* inside C:\Users\username\Desktop\tmp\ANT\Office\Stuff\ This was not at all intended or wished for.

It seems "squarechecking" a directory does not sync other directories inside it but files it does. Furthermore always the server filepath starting from / is generated.

Is there a possibility to put my original plan into action?

Thanks in advance
Philipp


#2

By chance I figured out how to achieve the desired behaviour:

  1. When adding an account, skip initial folder configuration.
  2. Finish account configuration
  3. Use add sync folder button on empty account
  4. Select local and remote folder as desired
  5. Complete the configuration

Done. Content of remote folder (and that content only) is synced with local folder (and there only). Exacty what I wished for. I have no idea why this doesn't work when configuring it while adding an account. Hopefully this will help others in the future.

Cheers
Philipp


#3

Hey @phi! Glad to see you found the workaround!

This has been reported quite a few times already and IMO needs to be fixed. You can :+1: in https://github.com/owncloud/client/issues/3664 to show your interest on this being solved.

Thanks for reporting! :wink: