Text Editor strange Keyboard behaviour


#1

Hey there, I’m new, sorry if I put this topic in the wrong section, but i’m experiencing something really strange.

I have an almost new installation of owncloud on my VPS, it’s for a friend who need to cooperate with other people with TXT files.

All went smoothly until I ran in a little issue when i show him how the owncloud works in a shared file, from his mobile phone, via Chrome browser, he cannot edit a TXT files properly, when he try to write something, words on files were different from words he typed. I try with another mobilephone, and it didn’t happen, so I said maybe is something temporary with your mobile.
I set up all the needed, and they start to work on files, from pc without problem.
He bought a new Huawei tab, and with google chrome, we have a similar issue, when you write someting like “Hello, how are you?” you can see he delete a letter every 2, so it writes “el,hwae yu”
You can see the deleted letter because it seems to me cursor stay on every second letter, so it is overwrited.
even enter to start new paragraf, it has been deleted
I don’t know if someone has the same issue, please help me to fix it.

Thank you, i’m available to send video of this problem.

John


#2

Hey, if i’m creating a new thread here i’m getting an issue template presented which is asking me various information like ownCloud version and similar which seems to be completely missing for your post.

I think that template is shown for a reason and its probably the best if you could spare some time and provide that information.


#3

Hi, sorry, and thank you for your answer, I didn’t know about the template, and it didn’t get to me.

I try to send all the informations i have:

OwnCloud version: 10.1.1 (stable)
my hoster is Hostiso, i’m using 6MB data storage, PHP version 5.6 and installation were made directly from hostiso “market app”
I have installed only Activity App and Texteditor App directly from Market
I have these error under the general admin settings:

  • Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking. See the [documentation :arrow_upper_right:] for more information.

  • We recommend to enable system cron as any other cron method has possible performance and reliability implications.

  • The “Strict-Transport-Security” HTTP header is not configured to at least “15552000” seconds. For enhanced security we recommend enabling HSTS as described in our [security tips].

  • No memory cache has been configured. To enhance your performance please configure a memcache if available. Further information can be found in our [documentation].

I left Cron settings as AJAX

I have a lot of little file, about 10k txt but storage data consumption is 6.3MB

Text editor works properly from any devices i used (PCs, MACs, iPhones and Androids phone), except for a not specified Galaxy Samsung phone with an old android 6, and a new Huawei MediaPad 5 emui version 8.0.0 kernel ver. 4.4.23

Hope this will help and it’s enough for you to have proper insight of the situation

Thank you in advance for all the help you will provide.

as I said before, if a video in needed, i have no problem to upload it

John.

Ps. even in the demo version in the owncloud/nextcloud website (i tried both) i cannot edit a txt file correctly with texteditor or collabora(openoffice).


#4

Hey,

as you’re running a recent version of ownCloud and that app i think it could be the best to report an issue to the author / maintainer of that app in https://github.com/owncloud/files_texteditor/issues. Maybe he/she knowns some incompatibilities with some specific browsers or mobile devices.


#5

thanks for your prompt answer, i’ll forward the problem in the right direction thanks to you.

John