"The data couldn't be read because it isn't in the correct format" iPhone app

help

#1

Hi!

I’m having trouble conecting to Owncloud through the iPhone app. Has anybody gotten this error message: “The data couldn’t be read because it isn’t in the correct format”

I run my Owncloud on a Raspberry Pi 3 and have no problems connecting through my Macbook. I’m also a complete noob.

Happy for any help :slight_smile:


#2

You get this error on connection?

Before seeing the files?


#3

Hi,

Sorry! I get this message after I press the “connect” button on the first page, after I’ve opened the app.


#4

Are you trying to connect with HTTP or HTTPS?

If HTTP, try HTTPS


#5

It looks like the client asks the server, but the response isn’t what the client expects. Does a firewall block something? Does the client gets redirected somewhere? Maybe check your webserver access log…

@crydestaahl I could have a closer look if you could send the URL of your ownCloud server to apps@owncloud.com


#6

I’m not really sure, how do I check that?


#7

Hi,

Where do I find the webserver access log?

Regarding this:
@crydestaahl I could have a closer look if you could send the URL of your ownCloud server to apps@owncloud.com

Do you want me to send you the address like: https://192.168.1.XXX?

Sorry for all the questions!


#8

https://192.168.1.XXX looks like an address in your internal network. It’s not reachable from the internet. That means there is nothing I can do to check.


#9

Maybe one of the following articles found within the ownCloud documentation could help here?

https://doc.owncloud.org/server/latest/admin_manual/issues/general_troubleshooting.html