The port 80 us block by my ISP

So here the problem,
My ISP us block the port 80, so it means I cannot portfoward it.
When I tried to connect (public_ip/owncloud) it only says Rejected request from RFC1918 IP to public server address.

I check with netstat that confirm me that the server what listenning on port 80.

Si i decided to tried to change the port owcnloud is using. I change the server.port to 8002 with my lighttpd server and portfoward it. After I checked with netstat and i found that the server was now listening on port 8002 (after a reboot)

However, if i tried to connec to public_ip:8002/owncloud , it only says This site is inaccessible
If a tried with public_ip/owncloud, it says the same error than before: Rejected request from RFC1918 IP to public server address.
I am still able to acces my server on local or via a vpn created in the raspberry pi (using dietpie), but i want to e able to connect with my public ip.

I dont know what to do, any suggestions ?

EDIT: I added my public ip to the trusted domain in the conf file, and change the URL to public_ip/owncloud and public_ip:8002/owncloud ( Itried both)

Where does this message come from? Is it an Apache/Nginx message?

@champymarty

check your config/config.php
trusted domains: you should have new port with your public_ip

public_ip:8002

More try to use https with port 443, if this is not blocked, then your ISP made a good choice by blocking port 80, it’s not safe at all, especially for ownCloud, as your connection is not secure.

If port 443 is not blocked then add in trusted domains:

public_ip:443

I will suggest you to use a DDNS if your public IP chances oft, you will have to change config.php every time, which is not nice.

@champymarty
you should reply, not edit your initial post, once someone responded.

@champymarty

delete /owncloud from config.php trusted domain is not needed.

you should have:

public_ip:8002

only.

Oh thank you, sorry for not responding I was out of town and I forgot to check my owncloud forum messages. I don’t think my ISP is blocking the 443 port. But i tried to add https but i am having some difficulties with it. Do you have any tutoriel link that you would recommend for my current config ? Yes i have a DDNS service, but i tried to set it up without it in the first place to see if it was the problem. I put a picture of the error i get when i trie to login with my punlic_ip.

Where are you trying to connect from? Have you tried both inside and outside your network?

@champymarty

did you add 443 port forward to your internal IP:443 in your router?

Ask your isp to open port 80 and 443

I did open port 443. I successfully setup a https connection i think, but still the same error. I am starting to think the problem might me coming from a other source, or maybe the https connection is not set propely. Any idea ?

What i did for the https: https://redmine.lighttpd.net/projects/lighttpd/wiki/HowToSimpleSSL

They will charge me extra. But i checked and only port 80 is block not 443.

Yes inside ( with my private ip in my home) it works but not with the public ip ( outside)

How did you check that 443 port is not blocked?

Without having owncloud running you should be able to connect to your webServer, from outside the private nework, with your public IP on port 443 once the Port Forwarding was made on router.

If this very first step works, then you can proceed further with owncloud, otherwise every effort making owncloud works, is useless.

In which country is this happening?