The requested URL not found

collabora

#1

Environment

  • OwnCloud 10.0.9.
  • Collabora is running on Docker.
  • Docker Host doesn’t have public IP Address. In order Collabora Code can be accesed from internet, I create iptables DNAT in other host (host X).
  • I don’t use reverse proxy.

Problem
When I use private IP address of Docker Host in Collabora Online setting in owncloud, I can use Collabora to edit file and etc. The problem is coming when i use Public IP Address of host X in Collabora Online setting in owncloud. I get error:

The requested URL /index.php/apps/richdocuments/WOPISrc=http://my-domain.com/index.php/apps/richdocuments/wopi/files/2404_ocbi5fufi26w&title=New Document.docx&lang=en&closebutton=1&revisionhistory=1&permission=readonly was not found on this server.

I hope someone can help me to fix the problem :slight_smile:


#2

Is this the full error message or have you redacted your private/public IP?

I would assume that something with the redirection / name resolution does not work.

If you have ownCloud in a docker container and collabora in a docker container, maybe you need to edit your etc/hosts file for the name resolution to work.

How did you setup ownCloud with collabora?


#3

My owncloud is running in different vm, not in docker. The full error that I got only the error that I posted above. There is no error that i found in collabora container & owncloud logs.

I integrate Collabora Code to OwnCloud using apps richdocument.

Yes, I edited manually /etc/hosts/ in Collabora Container. If I use local IP Address in /etc/hosts:

10.1.1.10 my-domain.com
10.1.1.20 collabora.my-domain.com

and in Collabora Setting in owncloud I use local IP address of Docker Host, Collabora is working well with OwnCloud. I can edit document and etc.

But if I use Public IP in Collabora Setting in owncloud and I also change /etc/hosts with public IP Address, Collabora Code is not working and I am getting the error above.

I don’t know why. Using local IP address is working well, but not for public IP Address.


#4

You are accessing via HTTP in both of those scenarios?


#5

Yes, I am using http for owncloud and collabora. I also try using https for owncloud and collabora, I got the same result.

I am wondering, is it an issue Collabora Code can not run behind/using iptables dnat?