The untrusted domains problem


#1

Hello all, I'm new in owncloud and setup a last 10 version in my raspberry pi and all works great!

Because my ISP block some ports and has a dynamic IP, I've use a no-ip DDNS.

The outbound connection from my "cloud.ddns.net" is routed by port 80 and in no-ip has changed to 8080, at last, my owncloud don't allow access (has blank page or untrusted domain).

some issues:

  • this "out" ip are dynamic and I can't put in config.php on the "trusted" section
  • the port are changed and changed again (no-ip = 80 to 8080, my router convert again 8080 to 80)

it's a Mikrotik cloud router

please can someone help about this? Any chance to "trusted all" with a "." or something else?


#2

Why bother about the IPs of DDNS. Just add the domain of no-ip into the trusted domain array.

'trusted_domains' =>
array (
0 => 'cloud.ddns.net',
),


#3

yes I do that and doesn't work... maybe is the port routing or something else... get a blank page, but in internal LAN all are ok...


#4

Have you installed the no-ip tool that tells no-ip your current IP address?
You can check by comparing your ip at whatismyip.com with the one currently stored in your no-ip account.

The ports should not be the issue. They are declared at the webserver. For nginx in the server {} statement.


#5

yes, the DUC is installed and running, my router pass the connection but the log:

Warning core Trusted domain error. "191.28.90.103" tried to access using "189.121.161.169:8080" as host.

these IPs are dynamic, and I can't solve this...

why not create a disable trusted domains feature?


#6

ops, I guess found the problem, I can't access in lan or outside the cloud by 80 port...

only SSL, it's a trouble (same blank screen)


#7

Then it's a problem in with your webserver. Which one do you have? Nginx or Apache?
Do you have a error log of them?


#8

Apache2

And every time a blank screen from outside


#9

So you can access via LAN? Can you post a error log?

Another possible reason for the failure could be that your provider uses Dual Stack Lite, which creates issues for a connection to your home server. See here: