This file wasn't available on site

i’m running infinite scale 6.0
when i try to download files from my personal space – photo. i got a message saying ‘This file wasn’t available on site’. When i click further, it told me ‘Try to sign in to the site and download again’. I’m already signed in. What could be wrong ? I was running the previous 5.X version and i did not have this error.

Which Identity Provider are you using?

Default identity provider. This is a simple setup out of the box.
The files are uploaded to the space folder via owncloud apps on my phone to sync with my phone’s photo folder. But when i login via web browser on my pc, view the photos and try to download the photo to my pc, i get that error.

If multiple selection and downloaded as zip, it is successful. But if i try to download the individual file, i will get the error. Strange.

That’s strange! Infinite Scale can be finicky sometimes. Have you tried restarting the ownCloud container or service? It might just need a nudge to refresh things.

Since this is my own installation, so i have the luxury to reinstall everything again. Still the same. Single file download still will give this error. This is the error that i got from the log file:

{“level”:“error”,“service”:“proxy”,“error”:“signature mismatch: expected ff89f1fb70a517a9769492cc4c156c50081cf299962290e43d4df76730e87958 != actual b588ca4d362f4498820bbc305a9f74cf3abde88f7ab49985b7578fa196e7e86b”,“authenticator”:“signed_url”,“path”:“/remote.php/dav/spaces/427f5037-cead-4d34-bd5e-ddbf9ddb4078$abb05cf8-8b88-4da8-b598-11b2180aff22/Photo/Photo-2024-07-05-16-06-18_4522.JPG”,“url”:“/remote.php/dav/spaces/427f5037-cead-4d34-bd5e-ddbf9ddb4078$abb05cf8-8b88-4da8-b598-11b2180aff22/Photo/Photo-2024-07-05-16-06-18_4522.JPG?OC-Credential=lee&OC-Date=2024-07-10T00%3A51%3A03.442Z&OC-Expires=1200&OC-Verb=GET&OC-Algo=PBKDF2%2F10000-SHA512&OC-Signature=b588ca4d362f4498820bbc305a9f74cf3abde88f7ab49985b7578fa196e7e86b”,“time”:“2024-07-10T08:51:05+08:00”,“message”:“Could not get user by claim”}

The weird thing is, multiple file download as a zip works fine. Only a single file download will give me an error.