This version of ownCloud is not compatible with PHP 7.3

After the final rollout of Debian Buster (10.0) as Debian stable and the dependency on PHP 7.3 Owncloud does not work any longer on my Server.
Are there any release plans when Owncloud 10.3 - which seems to support PHP 7.3 - will be available?


it’s not always right on time but there you go.


Thanks @cs35 Haven’t seen that yet. Sorry

It actually works fine - but you do have to edit index.php and console.php to just comment out the version check, I’m running it on a pi 4 with an Arm processor using PHP 7.3 … I got the same error and just removed the check…

I’m not recommending it being the way to go… but it works for me :slight_smile:

I do get a warning about code integrity … but I would expect that, and I wouldn’t keep it modified. I would only modify it until support is official

Can you elaborate on what you commented out? I’m trying to get my pi server running and I commented out the 4 or so lines for the 7.3 check but it’s still giving me issues.


it should be released soon (yeah it was for august, but I think it will come soon) so I wouldn’t go down the road of modifications.

1 Like

Is there a workable solution to continue using php 7.2 while owncloud is warning me that I use php 7.3. The foregoing discussion is beyond my simple comprehension. :wink:


same issue is here.i am very upset

Where did this update/upgrade came from. Have not seen a mention or warning, nor have I been asked to install it? I did not do an update or upgrade on the raspi. Is there some small print in the user license for owncloud that makes this possible?

Actually, I tried this and it does not work on my raspi 3b running raspbian buster.
I have no idea why it “just” does not work. Commented out the checks in /var/www/owncloud/ on both index.php and console.php and restarted nginx.
If there are new insights on how to work with 2 versions of php-fpm I am glad to hear/read them.


For Debian and Ubuntu based installation use this. With it you should be able to install any PHP version you might need.

1 Like

You are very optimistic. Needed sudo apt-get install software-properties-common
Tried to install the PPA, but: sudo add-apt-repository ppa:ondrej/php came back with a python error.
Traceback (most recent call last):
File “/usr/bin/add-apt-repository”, line 95, in
sp = SoftwareProperties(options=options)
File “/usr/lib/python3/dist-packages/softwareproperties/”, line 109, in init
File “/usr/lib/python3/dist-packages/softwareproperties/”, line 599, in reload_sourceslist
File “/usr/lib/python3/dist-packages/aptsources/”, line 93, in get_sources
(, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Raspbian/buster

Ah sorry, ARM builds are something else, you might have to compile yourself.

1 Like

Good news! I was unsuccessful to install the PPA from What I did was performing the instructions found in his wiki on Managing Multiple Versions by hand:
> sudo update-alternatives --set php /usr/bin/php7.2
update-alternatives: using /usr/bin/php7.2 to provide /usr/bin/php (php) in manual mode
> sudo update-alternatives --set php-config /usr/bin/php-config7.2
> sudo update-alternatives --set phpdbg /usr/bin/phpdbg7.2
update-alternatives: error: alternative /usr/bin/phpdbg7.2 for phpdbg not registered; not setting
> sudo update-alternatives --set phpize /usr/bin/phpize7.2

After these instruction the world seemed unchanged and I decided to wait it out.
Yesterday I needed my Pi for something and switched it on again. My xubuntu computer suddenly asked me for the OwnCloud password. I was amazed, but OwnCloud was working again. I checked the PHP version it is working on now and it was the former version 7.2.
My problem is solved for now!:sweat_smile:

1 Like

I was able to get this working on Debian 10 buster by following these steps:

sudo bash README.txt
sudo apt-get install php7.0
sudo a2dismod php7.3
sudo a2enmod php7.0
sudo systemctl restart apache2

For some reason, the php7.0 cURL and zip modules were not installed on my system, but I just went into aptitude and found php-curl and php-zip and made sure that the php7.0-curl and php7.0-zip packages were installed.

1 Like

This is now resolved with the 10.3.0 release. We have identified TOTP and one more app as not yet compatible and are working to release them ASAP.


“This version of ownCloud is not compatible with PHP 7.5
You are currently running PHP 8.0.3.”

OwnCloud 10.6.0

PHP 8 is not supported. See the requirements at

ownCloud can run with following PHP versions: 7.2, 7.3, and 7.4



Thanks! Just wonder why freebsd package named “owncloud-php80-10.6.0”

That you will have to ask the package maintainer :wink:

1 Like