Timeout because of to large header?

10

#1

Google was no help with this. I get this error on sync one folder. There is no clue why this happens right now. Nothing changed. I have only added more files to the folder. The same happens with other clients too. I have tried to raise settings in nginx.
client_header_buffer_size
large_client_header_buffers
client_header_buffer_size
http2_max_header_size
http2_max_field_size

Server Error (owncloud old install allways up to date 10.0.9.5):
19568#19568: *5571 client sent header field with too long length value while processing HTTP/2 connection

Owncloud Client (Linux error: Connection timed out

**Operating system: Gentoo Stable

**Web server: Nginx 1.15.2-r1

**Database:Mariadb

**PHP version:7.1

**OwnCloud version:10.0.9.5 old install allways updated update channel Production

**Where did you install ownCloud from: owncloud.org

occ config:list system
{
“system”: {
“memcache.local”: “\OC\Memcache\APCu”,
“instanceid”: “ocb4eef0f5ee”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“wolke.info”
],
“datadirectory”: “/srv/hps/oc/wolke/owncloud/data”,
“dbtype”: “mysql”,
“version”: “10.0.9.5”,
“dbname”: “dgsf_wolke”,
“dbhost”: “localhost”,
“dbtableprefix”: “oc_”,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“installed”: true,
“forcessl”: true,
“mail_smtpmode”: “smtp”,
“mail_from_address”: “REMOVED SENSITIVE VALUE”,
“mail_domain”: “REMOVED SENSITIVE VALUE”,
“preview_libreoffice_path”: “/usr/bin/soffice”,
“theme”: “”,
“maintenance”: false,
“secret”: “REMOVED SENSITIVE VALUE”,
“loglevel”: 2,
“trashbin_retention_obligation”: “auto”,
“mysql.utf8mb4”: true
}
}

ATTENTION: Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove all host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

occ app:list
Enabled:
  - activity: 2.3.7
  - calendar: 1.5.7
  - comments: 0.3.0
  - configreport: 0.1.1
  - contacts: 1.5.4
  - dav: 0.3.2
  - federatedfilesharing: 0.3.1
  - federation: 0.1.0
  - files: 1.5.1
  - files_external: 0.7.1
  - files_pdfviewer: 0.9.0
  - files_sharing: 0.10.1
  - files_texteditor: 2.2.1
  - files_trashbin: 0.9.1
  - files_versions: 1.3.0
  - files_videoplayer: 0.9.8
  - firstrunwizard: 1.1
  - gallery: 16.1.0
  - market: 0.2.5
  - notifications: 0.3.4
  - phonetrack: 0.2.8
  - provisioning_api: 0.5.0
  - systemtags: 0.3.0
  - templateeditor: 0.3.1
  - updatenotification: 0.2.1
Disabled:
  - encryption
  - external
  - files_antivirus
  - theme-example
  - user_external

#2

I’m not sure if ownCloud supports HTTP2 officially, but you can try to disable it for now and check what happens.

Is this the official desktop client? I’m not sure if the client logs can show what is the failing request and / or what is the problematic header


#3

I have tried to disable http2. Error message stays the same. I think the error refers to something else with http/2.
It’s the desktop client, but have the same on an other webdav client on my phone. It’s always breaks up on some file with timeout. The client always stops on same file, the app on my phone always on a different file(s). Could this even happen due to a new kernel on the server?


#4

The http2 wasn’t correctly disabled. I had to disable it on every server block with that ip. It actually works without http2.


#5

If there are other clients affected, maybe it’s the server (nginx) the one that is misbehaving