Timeout because of to large header?


#1

Google was no help with this. I get this error on sync one folder. There is no clue why this happens right now. Nothing changed. I have only added more files to the folder. The same happens with other clients too. I have tried to raise settings in nginx.
client_header_buffer_size
large_client_header_buffers
client_header_buffer_size
http2_max_header_size
http2_max_field_size

Server Error (owncloud old install allways up to date 10.0.9.5):
19568#19568: *5571 client sent header field with too long length value while processing HTTP/2 connection

Owncloud Client (Linux error: Connection timed out

**Operating system: Gentoo Stable

**Web server: Nginx 1.15.2-r1

**Database:Mariadb

**PHP version:7.1

**OwnCloud version:10.0.9.5 old install allways updated update channel Production


#2

Could you check what is the header that is giving trouble? I don’t know if the error will be in the nginx error log or if you need some flag to get that information.

Meanwhile, as a workaround, try disabling http2 from nginx.