Total Noob here


#1

Hello, I have my owncloud installed on my freenas server. While I am at home my owncloud works great from my android app.
While i am away from home my instant-upload fails due to a connection error. I have poured over many chats and fourm's and it starts to look like a foreign language after about 3 pages.
I just want to take a picture from anywhere w/ cell reception and have the file upload to my home server. Any guides for dummies? Or help out there for a noob.


#2

So what have you done to make your home ownCloud installation available from the outside?


#3

Hi mrdoggiedog.

This is where it starts to get tricky. To try and keep this simple, you need to configure your home firewall to allow access from any internet IP to your owncloud server. HOWEVER doing this opens up your owncloud / freenas to the internet from anyone to try and log in. If that's not bad enough, you probably do not have Secure HTTPS configured and so if you do the above, and someone captures the network traffic they can retrieve your username and password and access your data. Actually, if HTTPS is not used they can technically capture the traffic as you're uploading and obtain it that way.

Lastly, to get to your owncloud server from the internet you need to know your public IP address, which may change periodically. You can fix this by asking your ISP for a static IP.

If this was me doing this from home I'd do these things;
1. obtain a free SSL certificate (you can google for this) OR at very least configure a self-signed cert (you will get browse warnings, and I'm not sure if the app. will work with a self-signed cert. But if you use webmin (a web UI for Linux) then it can help set up a basic self signed cert

  1. configure your firewall to allow access from the internet to your server.

With the above 2, you can access the server securely.

It might be easier for you to not do the above, but link owncloud in to dropbox. Then use dropbox from your phone, and have owncloud download the files to itself from dropbox.


#4

I tried using webdav with port 8080or 81 cant really remember, i have tried various things with no effect.


#5

Thank you tony, that could be a good idea, using the dropbox idea, i think the issuse i am having. Is i am using port 80 to access my freenas system from my cell phone. I do have a self-signing cert. To access my freenas. Could that be causing the problem?


#6

Hi,

it seems that you need to start learning the basics first. Pages like https://portforward.com/ could help you here.