TOTP activation prevents login to desktop app

Activating TOTP in the Personal > Security settings prevents a user from logging into the desktop app.
The password input is returned as invalid and there is no way to enter the 2FA code.

Deactivating 2-Factor Authentication revalidates the password.

Windows 11 + ownCloud community install w/ ownCloud 2-Factor Authentication app

Please activate OAuth 2.0 app for login on your ownCloud server. It uses your web browser for login, and there you can enter your TOTP.

1 Like

Thank you - it almost worked…

Everthing worked once, and then it sent me into a loop of authorisation requests via the browser → “invalid credentials” response from the desktop app.

[EDIT:] The status symbol on the desktop app (Ubuntu 20.10) turned to grey with three dots, like a pause symbol. But the menu suggested that it was actually still synchronising.

If you have any advice I’m happy to listen. Caveat: I’ve had my ownCloud install for about a week, and I’m not a developer.

Thanks again - and thank you for an awesome application!

Check the requirements of the OAuth 2.0 app. Make sure you have all the Apache modules running:
Open Authentication (OAuth2) :: ownCloud Documentation

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.