TOTP Second-factor Auth won’t activate REOPEN

Steps to reproduce

  1. Login
  2. Click on Setting menu link
  3. Click on Security
  4. Check Activate TOTP

Expected behaviour

It should display a QR code and 2FA config code with field to confirm setup.

Actual behaviour

Nothing happens. No QR Code or 2FA config code.

Server configuration

Operating system : ubuntu 20

Web server: Apache 2.4

Database: MySQL 5.7

PHP version: PHP 8.1
Same result with PHP 8.1

ownCloud version: 10.11

Updated from an older ownCloud or fresh install: Updated from 10.8.0

Where did you install ownCloud from: [

Existing user with TOTP Second-factor Auth activated work fine.

New users cannot activate TOTP Second-factor Auth. Checking the box gives not additional steps to activate.

I look in the oc_twofactor_totp_secrets table do see the two user that tried today have records with secret keys that have not been verified. So it is partially doing something, but not allowing the process to complete by giving the necessary info to the user.

Any suggestions on where to start looking?

I have same problem.
I install new version of ImageMagick with this link
…manual_imagick7.html
but doesen’t work

Schermata 2022-11-10 alle 14.56.20

Please check the ownCloud and Apache log. The issue is most likely related to a broken/not working ImageMagick setup.

Have you really followed all instructions from Install an Updated ImageMagick Version :: ownCloud Documentation including the PECL installation of the required PHP wrappers?

PHP version: PHP 8.1
Same result with PHP 8.1

Please remember that PHP 8 is not supported and will not work.

yes I use this instructions for install imagemagik end pecl

this is the problem?
how do I remove php8 ?

How have you installed it? How to remove it depends on your OS and the used package manager, if you are using a VM it might be easier to create a new one and start from scratch.

I removed 8.1,
but the TOTP doesent view ;(

thx, I resolved with install PCL installation

another info:

  • Transactional file locking should be configured to use a memory-based locking method, not the slow default database-based method. See the [documentation :arrow_upper_right:] for more information.

I’d recommend to see the documentation in the link for more information.