Transactional file locking error with redis and php-redis installed


#1

Hello everybody,

I have the following error in my ownCloud web admin section:

Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking. See the documentation :arrow_upper_right: for more information.

The thing is: I have install both redis-server and php-redis and added the relevant configuration in config.php, as is documented in the documentation, but the error remains. Interestingly, when I change the local cache for APCu to Redis I get an error. Redis is up and running according to service redis-server status. No matter what I try, I can’t get it to work.

Server configuration

Operating system: Debian 9 (Stretch)

Web server: Apache/2.4.25

Database: PostgreSQL 9.6.10

PHP version: PHP 7.0.30-0+deb9u1

ownCloud version: 10.0.10.4

Updated from an older ownCloud or fresh install: Updated

Where did you install ownCloud from: Packages from owncloud repository

Signing status (ownCloud 9.0 and above): No errors have been found

The content of config/config.php: https://gist.github.com/Bliepo2/dc8cd6aa78ed9aa3817986e9c50c765e


**List of activated apps:**
Enabled:
  - activity: 2.3.8
  - calendar: 1.6.0
  - comments: 0.3.0
  - configreport: 0.1.1
  - contacts: 1.5.4
  - dav: 0.4.0
  - federatedfilesharing: 0.3.1
  - federation: 0.1.0
  - files: 1.5.1
  - files_antivirus: 0.13.0
  - files_external: 0.7.1
  - files_pdfviewer: 0.9.0
  - files_sharing: 0.11.0
  - files_texteditor: 2.2.1
  - files_trashbin: 0.9.1
  - files_versions: 1.3.0
  - files_videoplayer: 0.9.8
  - firstrunwizard: 1.1
  - gallery: 16.1.0
  - guests: 0.5.0
  - market: 0.2.5
  - notifications: 0.3.5
  - provisioning_api: 0.5.0
  - systemtags: 0.3.0
  - templateeditor: 0.3.1
  - twofactor_totp: 0.5.1
  - updatenotification: 0.2.1
Disabled:
  - encryption
  - external
  - user_external

**Are you using external storage, if yes which one:** no

**Are you using encryption:** no

**Are you using an external user-backend, if yes which one:** No

### Client configuration
**Browser:** Firefox

**Operating system:** Windows 10

#2

I think most of the setup use an ip address or a hostname (maybe localhost) to access to redis. If you’re using an unix socket, verify ownCloud (apache) can access to the socket


#3

Hey,

maybe the PHP redis module is also just not loaded even if the php-redis package was installed?


#4

I managed to solve the issue. Turns out I was still using PHP 5 instead of 7. I did have php7-cli installed, which led me to believe I was using the correct version, but I still had to install the php7.0 metapackage. After doing so and disabling PHP5 (a2dismod) and enabling PHP 7 (a2enmod) the issue was resolved.

Thanks for your help! It was due to your suggestions I tried using a port instead of a socket and discovered that the issue must be something more fundamental.