Transactional File Locking FreeNAS (FreeBSD)


#1

Hi
I'm running ownCloud in a FreeNAS 9.10-2 jail. I'm currently running OC 10.0.2. In the admin page, I'm getting the following error: transactional file locking should be configured to use memory-based locking, not the default slow database-based locking.
I tried the following to install redis and make it work:

  1. pkg install redis
  2. download php redis from here: https://github.com/phpredis/phpredis/
  3. run "phpize", then "/configure", then "make && make install" to install the php-redis component. redis.so has been copied into the appropriate folder
  4. add this line to the php.ini: extension=redis.so
  5. add the following to the OC config.php:

'memcache.locking' => '\OC\Memcache\Redis',
'redis' => array(
'host' => 'localhost',
'port' => 6379,
),

6.. Restart lighttpd (yes, I'm running lighttpd because it's lighter than apache and seems to work fine so far).
7. Long before, I configured OC to use APCu, which seems to work fine as well (I don't have any related errors)
8. I also tried /var/run/redis/redis.sock as host with port 0, as described here: https://doc.owncloud.org/server/10.0/admin_manual/configuration_server/caching_configuration.html

I haven't done any configuration to the redis server. I can confirm that it's running. I'm running everything with PHP56.