Transactional file locking should be configured to use memory-based locking

,

“I’m facing an issue with the error message ‘Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking’. I’m trying to resolve it by following the solutions available in the documentation, such as installing Redis or APCu. I’m using PHP 7.4 and Owncloud 10.13.3. Every time I attempt to append to a file, for instance ‘memcache.local’ => ‘\OC\Memcache\APCu’, located in /owncloud/config/config.php, my website stops displaying.”

Hey,

i’m using the following entries in my config.php:

  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
  ),

together with the following installed packages on Debian which seems to work quite well:

php-apcu
php-apcu-bc
php-redis

Zrzut ekranu z 2023-11-24 22-16-14
I installed the packages and added what you mentioned. It’s better now because at least there is a message appearing, but it’s still not it.

Hey,

i think the “More details can be found in the server log” info from the screenshot could maybe help to know the reason of the internal server error.