"trusted_domains" dyndns webhop


#1

Hello
Sorry if I posted in the wrong place or wrong.
I’m trying to set up my owcloud x server but I’m getting caught up in something. “trusted_domains”

http://177.189.244.193:90/owncloud
OK
but
cloud.atlastecnologia.com.br
The connection to cloud1.atlastecnologia.com.br was declined.
and entered with:
cloud1.atlastecnologia.com.br:90/owclooud
trusted domains.

Someone could give me strength.

atte. willian


#2

https://doc.owncloud.com/server/10.0/admin_manual/installation/source_installation.html#managing-trusted-domains

You have to add your domain to the trusted domain array in your config.php


#3

negative

‘trusted_domains’ =>
array (
0 => ‘localhost’,
1 => ‘cloud.atlastecnologia.com.br’,
2 => ‘192.168.0.251’,
),
‘datadirectory’ => ‘/var/www/owncloud/data’,
‘overwrite.cli.url’ => ‘cloud.atlastecnologia.com.br’,
‘dbtype’ => ‘sqlite3’,
‘version’ => ‘10.0.10.4’,
‘logtimezone’ => ‘UTC’,
‘installed’ => true,
);

Is this correct, my configuration above?
observation: I use port 90

atte. willian


#4

what URL are you entering in your browser when accessing ownCloud?

cloud.atlastecnologia.com.br?

and you have no proxy or redirect?


#5

url:
cloud.atlastecnologia.com.br

I do not use proxy


#6

I’m redoing a clean installation


#7

Hey,

from what i know whats configured within the trusted_domains is the info which is passed by your web server via the Host: header to ownCloud.

So if you have configured cloud.yourdomain.com.br within the trusted_domains setting but your web server is sending something differently the message about the untrusted domain is showing up.


#8

Hello Tom
With the new installation I got success for following dyndns domain. cloud1.atlastecnologia.com.br:90/owncloud
however masked mastery still succeeded, the domain would be this: cloud.atlastecnologia.com.br
I’m also doing tests with pydio, for it was successful.


#9

Hello Dimitry

‘trusted_domains’ =>
array (
0 => ‘192.168.0.251’,‘cloud1.atlastecnologia.com.br’,‘cloud.atlastecnologia.com.br’,‘atlastecnologia.com.br’,
),
‘datadirectory’ => ‘/var/www/html/owncloud/data’,
‘overwrite.cli.url’ => ‘http://192.168.0.251:90/owncloud’,
‘dbtype’ => ‘mysql’,

with url: cloud1.atalstecnologia.com.br:90 /owncloud
I succeeded.
but with url: cloud.atlastecnologia.com.br
I have a blank page with the following message:
The connection to cloud1.atlastecnologia.com.br was declined.


#10

Wrong syntax?

array (
    0 => '192.168.0.251’,
    1 => ‘cloud1.atlastecnologia.com.br’,
    2 => ‘cloud.atlastecnologia.com.br’,
    3 => ‘atlastecnologia.com.br’,
 ),

#11

Hello Alfred

with this structure I get the same result.
cloud.atlastecnologia.com.br

blank page, msg refused connection


#12

Hey,

when opening your URL i can find the following:

Sorry, your browser does not support frames.

I don’t think that ownCloud is allowing to be included within frames for security reasons. Instead of using a such a dyndns service using iframes maybe it could make sense to get a “real” domain or search for a provider not using iframes?


#13

I believe that is not the case, as I tested with pydio and it worked, even dyndns webhop, same port


#14

WEBHOP DYNDNS

Hostname:cloud.atlastecnologia.com.br
WebHop:Redirect URL:
http://cloud1.atlastecnologia.com.br:90/owncloud
Yes, Cloak This Page
Cloaked Page Title:
cloud.atlastecnologia.com.br


#15

Did you also try:

‘overwrite.cli.url’ => 'http://cloud1.atlastecnologia.com.br',

#16

Hey,

if both doesn’t have such security measures like ownCloud then i think its expected that those are working.


#17

I’ve done it before and have now re-created it.
unsuccessfully


#18

So if I open cloud1.atlastecnologia.com:90 I get your cloud. This brings me to the assumption that the code in your frameset might be wrong.

<frame src="http://cloud1.atlastecnologia.com.br:90/owncloud" name="redir_frame" frameborder="0"
scrolling="auto" noresize="noresize" marginheight="0" marginwidth="0"/>

Could you try src="http://cloud1.atlastecnologia.com.br:90", omitting the ‘/owncloud’?


#19

Where do I see this question of frames?


#20

By showing the source of http://cloud.atlastecnologia.com.br/.