Trusted domains not working

I’ve set up an owncloud server in docker, and while it appears to be perfectly functional nothing I try no matter the different variations will make the trusted domains work. I’ve followed everything in the documentation exactly, and the file is definitely in use - if I intentionally mess up the format it’s loaded, but it will not implement any functionality it’s supposed to.

Steps to reproduce

  1. Started a new owncloud server
  2. Whitelisted local ip and WAN hostname
  3. Attempt to connect on anything other than localhost

Expected behaviour

Connecting to the service should work

Actual behaviour

I received a trusted domain error no matter what is attempted

Server configuration

Operating system:
Windows 10

Web server:


PHP version:

ownCloud version: (see ownCloud admin page)
10.12.1 stable

Updated from an older ownCloud or fresh install:
fresh install

Where did you install ownCloud from:
github via docker desktop


$CONFIG = array (
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/var/www/owncloud/apps',
      'url' => '/apps',
      'writable' => false,
    1 => 
    array (
      'path' => '/var/www/owncloud/custom',
      'url' => '/custom',
      'writable' => true,
  'trusted_domains' => array (
    0 => 'localhost',
    1 => '',
  'domain' => 'localhost',
  'datadirectory' => '/mnt/data/files',
  'dbtype' => 'sqlite',
  'log_type' => 'owncloud',
  'supportedDatabases' => 
  array (
    0 => 'sqlite',
    1 => 'mysql',
    2 => 'pgsql',
  'upgrade.disable-web' => true,
  'default_language' => 'en',
  'overwrite.cli.url' => '',
  'htaccess.RewriteBase' => '/',
  'logfile' => '/mnt/data/files/owncloud.log',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => true,
  'passwordsalt' => 'IsHKalVg9iJKTDO+qHBUmPIZjFIQTW',
  'secret' => 'Oo/+BJrVFRPVheHRMjTMx2+JweR/5mFL7fJBTk5guqkcQhwz',
  'version' => '',
  'allow_user_to_change_mail_address' => '',
  'logtimezone' => 'UTC',
  'installed' => true,
  'instanceid' => 'ocpp9apit2p5',

Not using external storage

Not using encryption

Not using external backend or LDAP

Client configuration


Operating system:
Windows 10

Hello, please take a look at Trusted domains - #34 by rkaussow


Thanks for the heads up. It could potentially be useful for the error dialogue that pops up to make note of the possibility of different settings for docker, at least. It would be even more ideal to not use a whole different system for docker, but I’m guessing there’s a complicated technical reason that’s done.


i think the reason why it currently can’t be done has been given here:

1 Like

I have the same problem, finally can you finded a solution?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.