Trying to get owncloud running on raspi 3

Cannot connect via LAN or web to my server when /var/www/html/owncloud/config/config.php has overwrite.cli.url set to https://myWANip/owncloud

Server configuration

Operating system:
Raspbian
Web server:
apache2
Database:
mysql
PHP version:
installed 7.2, but 7.3 seems to be running?
ownCloud version: (see ownCloud admin page)
10.0.10
Updated from an older ownCloud or fresh install:
Fresh
Where did you install ownCloud from:
https://download.owncloud.org/community/owncloud-10.0.10.tar.bz2

The content of config/config.php:

<?php
$CONFIG = array (
  'instanceid' => 'xxxxxxxxxxxxxxxxxxx',
  'passwordsalt' => 'xxxxxxxxxxxxxxxxxxxxx',
  'secret' => 'xxxxxxxxxxxxxxxxxxxxxxxx',
  'trusted_domains' => 
  array (
    0 => '10.0.0.148',
1 => 'wan ip',
  ),
  'datadirectory' => '/var/www/html/owncloud/data',
  'overwrite.cli.url' => 'https://wan ip/owncloud',
  'dbtype' => 'mysql',
  'version' => '10.0.10.4',
  'dbname' => 'owncloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'me',
  'dbpassword' => 'mypass',
  'logtimezone' => 'UTC',
  'installed' => true,
);


pi@raspberrypi:/var/www/html/owncloud $ sudo -u www-data php occ config:list system
This version of ownCloud is not compatible with PHP 7.3
You are currently running PHP 7.3.4-2.
pi@raspberrypi:/var/www/html/owncloud $ cd
pi@raspberrypi:~ $ a2dismod php7.3
ERROR: Module php7.3 does not exist!
pi@raspberrypi:~ $ sudo a2dismod php7.3
ERROR: Module php7.3 does not exist!
pi@raspberrypi:~ $ a2enmod php7.2
Considering dependency mpm_prefork for php7.2:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php7.2:
Module php7.2 already enabled
pi@raspberrypi:~ $ 

Are you using external storage, if yes which one: local/smb/sftp/…
no

Hey,

maybe you can describe what “Cannot connect via LAN or web to my server” means? I think this has too less information to help here as it could mean everything :slightly_frowning_face: