Ubuntu installation issues - unmet dependencies

help

#1

Hello!

After initially experiencing trouble getting the OC client to sync with the server (since fixed by the hosting provider), I subsequently attempted to upgrade from version 1.8 to 2.2 which has been rather disastrous. Since version 2.2 was not available via Ubuntu's software centre, I initially attempted to manually install version 2.2 and later version 1.8 (without first removing version 2.2) and now I am unable to install anything. When attempting to install OC through the Ubuntu software centre I receive the following error message:

The following packages have unmet dependencies:

owncloud-client: Depends: libc6 (>= 2.14) but 2.21-0ubuntu4.3 is to be installed
Depends: libgcc1 (>= 1:3.0) but 1:5.2.1-22ubuntu2 is to be installed
Depends: libowncloudsync0 (= 2.2.2-19.1) but 2.2.2-19.1 is to be installed
Depends: libqt5core5a (>= 5.5.0) but 5.4.2+dfsg-2ubuntu9 is to be installed
Depends: libqt5dbus5 (>= 5.0.2) but 5.4.2+dfsg-2ubuntu9 is to be installed
Depends: libqt5gui5-gles (>= 5.0.2) but 5.4.2+dfsg-2ubuntu9 is to be installed
Depends: libqt5network5 (>= 5.0.2) but 5.4.2+dfsg-2ubuntu9 is to be installed
Depends: libqt5webkit5 (>= 5.0.2) but 5.4.2+dfsg-1ubuntu2.1 is to be installed
Depends: libqt5widgets5 (>= 5.2.0) but 5.4.2+dfsg-2ubuntu9 is to be installed
Depends: libqt5xml5 (>= 5.0.2) but 5.4.2+dfsg-2ubuntu9 is to be installed
Depends: libstdc++6 (>= 5.2) but 5.2.1-22ubuntu2 is to be installed

By the way, I did manage to run OC in Wine, yet this is a sub-optimal outcome due to the lack of integration with Ubuntu's file manager.

Does anyone have any suggestions on how to get OC to work again?


#2

You should choose the correct repository from:

https://owncloud.org/install/#install-clients

matching your Ubuntu version. The packages there are providing the correct dependencies.


#3

You are right, I did install the wrong version. However, when I installed the correct version, I received this error message:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
owncloud-client : Depends: libowncloudsync0 (= 2.2.2-19.1) but it is not going to be installed
Depends: libqt5core5a (>= 5.5.0) but 5.4.2+dfsg-2ubuntu9 is to be installed
Depends: libqt5keychain1 but it is not going to be installed
Depends: owncloud-client-l10n but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


#4

Still looks like a wrong chosen repository


#5

I fear I may have "burned" my system by installing several OC versions at the same time.

I am using Zorin 11, which is based on Ubuntu 15.10. Is there anything that could be done to fix this?


#6

This "Zorin" probably is not completely based on Ubuntu 15.10 and just provides not all necessary dependencies. Do they have a support forums where you can ask for support?


#7

Usually there are no issues (www.zorinos.com). Remember that version 1.8 installed fine using the Ubuntu software centre. In hindsight it was pretty stupid to install an older version of OC while version 2.2 was still installed..


#8

Just report an issue at:

https://github.com/owncloud/client/issues

if you think there is an issue with the packages itself


#9

Ref: