Ubuntu release upgrade 16.4 to 18.4: cURL issue


#1

I had a working installation on Ubuntu 16.04 server, and I got problems after Ubuntu 18.04.1 release upgrade.

Is that: normal, known ?
Have I to reinstall owncloud from scratch ?

Steps to reproduce

  1. Performed Ubuntu 18.4 release upgrade
  2. NOR removed old packet during upgrade
  3. Try to access owncloud service

Expected behaviour

I would expect to access owncloud service without problems

Actual behaviour

Client installed on workstation PC claim: user disconnected.
Service WEB page (my.domain/owncloud/ states: PHP cURL module not installed

Server configuration

Operating system:
Ubuntu 18.04.01

Web server:
Server version: Apache/2.4.29 (Ubuntu)
Server built: 2018-10-10T18:59:25

Database:
mysql Ver 14.14 Distrib 5.7.24, for Linux (x86_64) using EditLine wrapper

PHP version:
PHP 7.2.10-0ubuntu0.18.04.1 (cli) (built: Sep 13 2018 13:45:02) ( NTS )

ownCloud version: (see ownCloud admin page)
“version”: “10.0.10.4”

Updated from an older ownCloud or fresh install:
Updated from previous release

Where did you install ownCloud from:
owncloud repository

Signing status (ownCloud 9.0 and above):
?

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

Cannot login

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

{
“system”: {
“instanceid”: “ocduitoeglfj”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
zappi.me
],
“datadirectory”: “/var/www/zappi.me/public_html/owncloud/data”,
“overwrite.cli.url”: “http://localhost”,
“dbtype”: “mysql”,
“version”: “10.0.10.4”,
“dbname”: “owncloud”,
“dbhost”: “localhost”,
“dbtableprefix”: “oc_”,
“mysql.utf8mb4”: true,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“logtimezone”: “UTC”,
“installed”: true,
“maintenance”: false,
“loglevel”: 2
}
}

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Enabled:

  • comments: 0.3.0
  • configreport: 0.1.1
  • dav: 0.4.0
  • federatedfilesharing: 0.3.1
  • federation: 0.1.0
  • files: 1.5.1
  • files_external: 0.7.1
  • files_sharing: 0.11.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • files_videoplayer: 0.9.8
  • firstrunwizard: 1.1
  • market: 0.2.5
  • notifications: 0.3.5
  • provisioning_api: 0.5.0
  • systemtags: 0.3.0
  • updatenotification: 0.2.1
    Disabled:
  • encryption
  • external
  • user_external

Are you using external storage, if yes which one: local/smb/sftp/…
No

Are you using encryption: yes/no
Use https with certificate, if this was the question.

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…
No

Client configuration

Browser:
Firefox 63.0.3

Operating system:
Windows 10 PRO Ver. 1803

Logs

Web server error log

Insert your webserver log here



#### ownCloud log (data/owncloud.log)

Insert your ownCloud log here

https://github.com/LucaZeta/Logs/blob/master/owncloud.log

#### Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log
c) …


#2

Hey,

i think while moving from Ubuntu 16.04 to 18.04 you have also updated the PHP (e.g. from PHP 5.6 to 7.0) but missed to make sure that all previously PHP extensions of 5.6 are also installed for 7.0.


#3

God idea tom42,
curl extention looks installed for both php.7.0 and php.7.2:
user@host: locate mods-available | grep -i curl
/etc/php/7.0/mods-available/curl.ini
/etc/php/7.2/mods-available/curl.ini
/var/lib/ucf/cache/:etc:php:7.0:mods-available:curl.ini
/var/lib/ucf/cache/:etc:php:7.2:mods-available:curl.ini

then I tried to:
sudo phpenmod curl
sudo service apache2 restart

But curl looks to owncloud server stll as not installed.
If you known some other procedure to follow, you will be welcome.


#4

Hey,

maybe you could ask in an Ubuntu forums or the support of your hoster how to correctly migrate a PHP installation so that the required modules are correctly enabled and provided to PHP applications like ownCloud?


#5

I agree with @tom42, that this is highly off-topic.