Unable to change Max upload Limit

upload_limit
9.1.x
help

#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce
1. try to update max upload limit through owncloud web
2.
3.

Expected behaviour
Tell us what should happen

When i change the max upload limit in owncloud for web and after setting up i did save. When reload the page max upload size came to default (2MB)

Actual behaviour
Tell us what happens instead

It should be updated

Server configuration
Operating system: Ubuntu 15.10
Web server: Apache/2.4.12
Database: 5.6.31
PHP version: PHP 5.6.11-1ubuntu3.4 (cli)
ownCloud version (see ownCloud admin page): 9.1.0
Updated from an older ownCloud or fresh install: updated from older version
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808):

      No error file generated as there was nnot any logs of php error

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): no additional configuration , just default configuration on which server was working perfectly earlier.

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

No errors have been found.


Maximum upload size not updating
#2

Did you install ownCloud from the repo's? Did you add something in your apache-config with

<Directory /var/www/owncloud>
AllowOverride All
... and more stuff ...
</Directory>

?

You could also change it in your php.ini, I think RealRancor already pointed you to the topic which lists most of the possibilities:


#3

I installed owncloud through tar file

also i did below

 <Directory /var/www/owncloud>
            AllowOverride All
            </Directory>

Now max upload limit is showing 10 GB but i am getting error while uploading file which you can see below.

Error uploading file "Win8_Pro_x86_EN-US_ISO_{CYCLONOID}.iso": Total file size 2.5 GB exceeds upload limit 2 MB


#4

You should check your .htaccess file in your owncloud dir. It most likely has lines like

php_value upload_max_filesize 513M
php_value post_max_size ??M
php_value memory_limit ??M

Apparently the values in your case are rather 2M
Change them to 5G for instance. But beware of the limitation of your server. If it runs in 32 bits the physical limit is 2G
You could also check your php.ini in /etc/php5/apache2 and change the lines

upload_max_filesize =
post_max_size =

with whatever value needed.
But as you have put an AllowOverride All directive in your virtualhost, this is the value in the .htaccess file which prevails.


#5

All solutions was the same in any google search.
I solved after 2 wks of brain cracking
with 9.1 upgrade a new file appear in the OC directory:
.user.ini
edit this with your value
example:
upload_max_filesize=10G
post_max_size=10G

and all works.
too many people write only to ask something but with no solution (or with google's solution)


#6

It also helps to just read the provided documentation:

https://doc.owncloud.org/server/9.1/admin_manual/configuration_files/big_file_upload_configuration.html