Unable to download files bigger than 2 GB

Steps to reproduce

  1. Go to ownCloud site via web.
  2. Choose a file bigger than 2 Gigabytes.
  3. Download the file.

Alternative way
Using Desktop App 2.11.1

  1. Open windows file explorer
  2. Choose a file bigger than 2 Gigabytes on the local
  3. Right click on the file
  4. Click on “Always keep on this device” option

Expected behaviour

Download a file greater than 2 Gigabytes successfully.

Actual behaviour

Via web: Once the file achieves 2GB the browser shows an error. Any retry ends up in the say error.
This behaviour is reproduced under Firefox, Edge and Chrome browsers.

Desktop client: Once the file achieves 2GB an error ocurrs: Closed connection.
No errors found in logs.

Server configuration

Operating system: Debian buster
Linux raspberry 5.10.103-v7+ #1529 SMP Tue Mar 8 12:21:37 GMT 2022 armv7l GNU/Linux

Web server:
Server version: Apache/2.4.38 (Raspbian)
Server built: 2022-06-20T19:03:00

Database:
mariadb Ver 15.1 Distrib 10.3.36-MariaDB, for debian-linux-gnueabihf (armv8l) using readline 5.2

PHP version:
PHP 7.3.31-1~deb10u1 (cli) (built: Oct 24 2021 15:18:08) ( NTS )

ownCloud version: 10.11.0

Updated from an older ownCloud or fresh install:
Update from 10.10
Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

The content of config/config.php:

{
    "basic": {
        "license key": "***REMOVED SENSITIVE VALUE***",
        "date": "Wed, 09 Nov 2022 21:04:20 +0000",
        "ownCloud version": "10.11.0.6",
        "ownCloud version string": "10.11.0",
        "ownCloud edition": "Community",
        "server OS": "Linux",
        "server OS version": "Linux raspberry 5.10.103-v7+ #1529 SMP Tue Mar 8 12:21:37 GMT 2022 armv7l",
        "server SAPI": "apache2handler",
        "webserver version": "Apache\/2.4.38 (Raspbian)",
        "hostname": "mysite.com",
        "logged-in user": "Admin"
    },
    "stats": {
        "users": {
            "Database": {
                "total_count": 5,
                "guest_count": 0,
                "seen": 5,
                "logged in (30 days)": 2
            }
        },
        "groups": {
            "OC\\Group\\Database": 2
        }
    },
    "config": {
        "instanceid": "oc1dmekxq9gz",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "192.168.1.111",
            "other.name.com",
            "second.name.com",
            "mysite.com"
        ],
        "datadirectory": "\/u01\/owncloud\/data",
        "overwrite.cli.url": "http:\/\/mysite.com\/owncloud",
        "dbtype": "mysql",
        "version": "10.11.0.6",
        "logtimezone": "UTC",
        "installed": true,
        "mail_smtpmode": "smtp",
        "mail_smtpsecure": "tls",
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpauthtype": "LOGIN",
        "mail_smtpauth": 1,
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpport": "587",
        "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
        "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
        "asset-pipeline.enabled": false,
        "loglevel": 2,
        "maintenance": false,
        "dbname": "owncloud",
        "dbhost": "127.0.0.1",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "htaccess.RewriteBase": "\/owncloud",
        "filelocking.enabled": true,
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "memcache.local": "\\OC\\Memcache\\APCu",
        "redis": {
            "host": "\/var\/run\/redis\/redis.sock",
            "port": 0,
            "dbindex": 0,
            "password": "***REMOVED SENSITIVE VALUE***",
            "timeout": 1.5
        },
        "theme": "",
        "upgrade.automatic-app-update": true,
        "allow_user_to_change_mail_address": ""
    },
    "phpinfo": {
        "apache2handler": {
            "Apache Version": "Apache\/2.4.38 (Raspbian)",
            "Apache API Version": "20120211",
            "Server Administrator": "webmaster@localhost",
            "Hostname:Port": "mysite.com:0",
            "User\/Group": "www-data(33)\/33",
            "Max Requests": "Per Child: 0 - Keep Alive: on - Max Per Connection: 100",
            "Timeouts": "Connection: 300 - Keep-Alive: 5",
            "Virtual Server": "Yes",
            "Server Root": "\/etc\/apache2",
            "Loaded Modules": "core mod_so mod_watchdog http_core mod_log_config mod_logio mod_version mod_unixd mod_access_compat mod_alias mod_auth_basic mod_authn_core mod_authn_file mod_authz_core mod_authz_host mod_authz_user mod_autoindex mod_deflate mod_dir mod_env mod_filter mod_headers mod_mime prefork mod_negotiation mod_php7 mod_proxy mod_proxy_http mod_reqtimeout mod_rewrite mod_setenvif mod_socache_shmcb mod_ssl mod_status",
            "engine": "1",
            "last_modified": "0",
            "xbithack": "0"
        },
}

List of activated apps:

**Are you using external storage, if yes which one:**no

Are you using encryption: no

Client configuration

Browser:
Firefox 106.0.5
Operating system:
Windows 10

Logs

Web server error log

No errors in the log

ownCloud log (data/owncloud.log)

No errors in the log

#### Browser log

Insert your browser log here, this could for example include:

Given the configuration above, I would try to disable the mod_reqtimeout Apache module. This module could be the cause for various problems like broken up-/downloads.

Thanks @pako81 but it didn’t work.
I did this:

sudo a2dismod reqtimeout
sudo systemctl reload apache2
sudo service apache2 restart

The behaviour is the same. The download fails at 2GB, if I try to restart it looks to download 2GB more but it fails every time it reaches 2GB. The file that should be 4.1GB can grow up until the infinite retrying.
That happens in Firefox, Chrome and Edge.

The thing is the uploads are working fine. I can upload files bigger than 2GB without problems.

Regards,
kaze

I copied a 4.3GB file in /var/www/html/repo directory and I am able to download it from my browser. It worked perfectly fine, without errors.
Something happens in OC only.