Unable to get an FTP Connection

Steps to reproduce

  1. Install External Storage FTP
  2. Add FTP as external Storage
  3. Enter Username/Password/Host/Port
  4. Leave the Root blank
  5. Add the Connection

Expected behaviour

FTP Connection Successfull, and after adding the External Storage, start the Files scan using “sudo -u www-data php files:scan -all”

Actual behaviour

A red square appears, not allowing the FTP connection to be established. Error Code shows: There was an error with message: League\Flysystem\FileNotFoundException: File not found at path: . Do you want to review mount point config in admin settings page?

Server configuration

Operating system: Ubuntu Server 18.04.3

Web server: Apache2

Database: MariaDB

PHP version: 7.2

ownCloud version: 10.3.1.1
Updated from an older ownCloud or fresh install:* Fresh install

Where did you install ownCloud from: Tarball

The content of config/config.php:
Not Changed

Are you using external storage, if yes which one: ftp

Are you using encryption: no

Are you using an external user-backend, if yes which one: None

Client configuration

Browser: Chrome

Operating system: Windows 10

Have you tried what happens if you enter a root directory in your settings?
Can you try your settings using a command line FTP client on the ownCloud server? (I think curl supports FTP)

Hi! When I add a directory manually, it loads indefinitely. The Ubuntu instance can reach the ftp instance no problem.
Edit: Using a Filezilla client on a different PC the FTP can be accessed

What kind of directory? What do you mean with manually (as opposed to??)? Are we still talking about an FTP connection here?

How did you test this? Ping? Can you actually browse the files?

EDIT: Have you checked the FTP documentation?

Instead of “root” i added “(foldername)/” yes still FTP, my description was unclear.

I used FTP on the Ubuntu command line. There i can browse the files on the FTP server.

1 Like

Hey,
I just found this bug:

Aaawh that sucks! Anyway thanks for your answers, when i have access tonight i will try a subdirectory

1 Like