Unable to login in the web interface

9.1.x
help

#1

Steps to reproduce
1. Try to login in the web interface

Expected behaviour
Login

Actual behaviour
The login page reloads without displaying any error

Server configuration
Operating system: archlinux arm (3.8.13.30-5-ARCH)
Web server: nginx 1.10.2
Database: mariadb 10.1.19
PHP version: 7.0.13
ownCloud version (see ownCloud admin page): 9.1.2
Updated from an older ownCloud or fresh install: updated
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

ownCloud log (data/owncloud.log)

{"reqId":"xxx",
"remoteAddr":"192.168.x.x",
"app":"no app in context",
"message":"Current user is not logged in",
"level":0,
"time":"2016-11-19T00:27:46+00:00",
"method":"GET",
"url":"\/index.php\/apps\/files\/",
"user":"--"}
{"reqId":"xxx",
"remoteAddr":"192.168.x.x",
"app":"core",
"message":"Error while running background job 
(class: OC\\Command\\CommandJob, 
arguments: O:33:\"OCA\\Files_Versions\\Command\\Expire\":4:
{s:43:\"\u0000OCA\\Files_Versions\\Command\\Expire\u0000
fileName\";s:38:\"\/LibreOffice\/registrymodifications.xcu\";s:47:\"\u0000OCA\\Files_Versions\\Command\\Expire\u0000
versionsSize\";i:174170471;s:46:\"\u0000OCA\\Files_Versions\\Command\\Expire\u0000
neededSpace\";d:2391002.5;s:39:\"\u0000OCA\\Files_Versions\\Command\\Expire\u0000
user\";s:7:\"nicolas\";}): 
{\"Exception\":\"InvalidArgumentException\",
\"Message\":\"Invalid serialized command\",
\"Code\":0,
\"Trace\":\"#0 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/BackgroundJob\\\/Job.php(52): OC\\\\Command\\\\CommandJob->run('O:33:\\\"OCA\\\\\\\\Files...')\\n
#1 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/BackgroundJob\\\/QueuedJob.php(42): OC\\\\BackgroundJob\\\\Job->execute(Object(OC\\\\BackgroundJob\\\\JobList), Object(OC\\\\Log))\\n
#2 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/cron.php(146): OC\\\\BackgroundJob\\\\QueuedJob->execute(Object(OC\\\\BackgroundJob\\\\JobList), Object(OC\\\\Log))\\n
#3 {main}\",\"File\":\"\\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/Command\\\/CommandJob.php\",\"Line\":36}",
"level":3,
"time":"2016-11-19T00:27:47+00:00",
"method":"GET",
"url":"\/cron.php",
"user":"--"}

More info
I tried admin user and classic users, none of them can login.
I tried different web browsers.
My desktop client and mobile client seem to synchronise well: no errors displayed. But when I try to display my stored files on my mobile client, the application freeze.

Firefox errors

Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src https://cloud.bananeatomic.fr 'unsafe-eval'”).  login:1
TypeError: can't access dead object  rtcDefault.xml:105:42

Update 20 November

  • I tried with a fresh installation on the same machine: I have the same problem
  • I switched from uwsgi to php-fpm and I managed to pass the login page !!! But now I faced a new problem:

Just after login, I arrived on the files app. A message is displayed on the top of the page:

Problem loading page, reloading in 5 seconds

And a kind of popup with this message is displayed in the center of the page:

This content failed to load.

I can navigate without problem, but every 5 seconds the entire page is reloaded and the 2 messages are displayed again.
Firefox errors:

02:38:26.857 TypeError: $box[0].style.removeAttribute is not a function 1 jquery.colorbox.js:649:6
	removeFilter apps/firstrunwizard/js/jquery.colorbox.js:649:6
	publicMethod.prep/callback apps/firstrunwizard/js/jquery.colorbox.js:749:5
	publicMethod.position/<.complete apps/firstrunwizard/js/jquery.colorbox.js:551:6
	n.speed/d.complete core/vendor/jquery/dist/jquery.min.js:3:29135
	n.Callbacks/j core/vendor/jquery/dist/jquery.min.js:2:26920
	n.Callbacks/k.fireWith core/vendor/jquery/dist/jquery.min.js:2:27738
	Xa/i core/vendor/jquery/dist/jquery.min.js:3:27719
	n.fx.tick core/vendor/jquery/dist/jquery.min.js:3:30845

02:34:47.249 "TabSources.prototype._fetchSourceMap threw an exception: SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Stack: SourceMapConsumer@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/sourcemap/source-map.js:1281:20
TabSources.prototype._fetchSourceMap/fetching<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/utils/TabSources.js:469:19
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:750:11
Line: 1281, column: 20" 1 ThreadSafeDevToolsUtils.js:80

#2

So this worked before and then stopped at some point in time?


#3

Exactly, but I don't really remember exactly when.
I tried to delete/rename the «owncloud/config/config.php» file and to create a new database, but it results in the same problem with the login.


#4

Hi,

then it will be quite hard to help here. Please do a research what was changed.


#5

I already tried to figure out what changed, unsuccessfully.
I hope there is something in my logs and in the error messages that will lead to identify the problem.


#6

I reinstalled version 8.2.9, which works well with uwsgi and php-fpm
I also reinstalled version 9.0.6, which has the «Problem loading page, reloading in 5 seconds» error message with php-fpm and which doesn't work with uwsgi.


#7

Hi,

this is an unsupported and untested combination. Please note:

  • Only Apache + mod_php is officially supported and tested
  • There is community support for nginx + php-fpm

#8

Hi,

Not uwsgi and php-fpm together!
It works well with owncloud version 8.2.9 + nginx + php-fpm.
And it also works well with owncloud version 8.2.9 + nginx + uwsgi.
But it doesn't work with owncloud version 9.1.2 + nginx + uwsgi.
And finally it works well with owncloud version 9.1.2 + nginx + php-fpm.

Do you know why uwsgi is not supported? Or why it starts to not work since 9.x?
Could you give me the link to the community support for nginx + php-fpm?

Thanks,


#9

Hi,

it is not used by the developers of ownCloud.

Support for this combination will be given in here.