Unable to mount External Storage with spaces in name


#1

Running 9.1.4 (stable) on Ubuntu server 16.04

The owncloud is using the AD LDAP plugin, I can add an SMB share that doesn't contain spaces but not one that does
- Storage not available exception

Is there anything in particular I need to do with spaces, escape them somehow?


#2

Hi,

make sure that you have [1] installed. If this is installed just report a new bug to the oC developers at [2].

[1] https://github.com/eduardok/libsmbclient-php

[2] https://github.com/owncloud/core/issues


#3

Thanks
The users will be using BYO devices so they will have admin access and no way to stop them from installing the client. I thought there might be a setting on the server side that disables it


#4

For what it's worth, I ran across a similar issue with external webdav storage (Box.com). It would not show folders with spaces. Easy fix in my case to just rename a few folders, but easy to miss on a long list of folders with subfolders if you didn't know the issue was there.

W.