Unable to trust the domain... inaccessible instance

I have been running owncloud via docker for quite some time but upgraded to 10.11.0.6 today and have been getting the following untrusted error ever since. No matter what I put into the trusted_domains on the config file i cannot seem to access our instance.

You are accessing the server from an untrusted domain.

Please contact your administrator. If you are an administrator of this instance, configure the “trusted_domains” setting in config/config.php. An example configuration is provided in config/config.sample.php or at the [documentation].

Is there a place that it logs what I am accessing the instance from? so I can ensure that it’s what it should be? This is incredibly frustrating… I currently have 7 ips/hostnames in my trusted_domains in hopes of capturing the requested url but it does not seem to resolve anything. I access the url files.mydomain from my browser which hits an haproxy instance that forwards to an nginx reverse proxy, which then hit an owncloud docker container. several machines/ips. which one is it complaining about? i’ve put every ip in along the way…

‘trusted_domains’ =>
array (
0 => ‘localhost’,
1 => ‘10.1.1.20’,
2 => ‘10.42.42.50’,
3 => ‘files.mydomain’,
4 => ‘10.42.42.50:8080’,
5 => ‘10.1.10.100’,
6 => ‘10.1.1.1’
),

What am I doing wrong?! What changed from 10.9 to 10.11 that broke this?!

I found that there was the option of an environment variable ‘OWNCLOUD_TRUSTED_DOMAINS’ that i set the same variables to… It appears that the docker version had an ‘overwrite.config.php’ file as well that was overriding the trusted_domains section of the config.php with that env variable or if undeclared the value of the env variable ‘OWNCLOUD_DOMAIN’. So if both of those env variables are undeclared then it sets the trusted_domains section in the config.php to an empty string. I hope this can help someone else before spending as much time diagnosing as I did.