Unable to update

10
hosting

#1

I’m only able to manually update via FTP all of my attempts to upgrade using CLI/Web fail.
If anyone can figure out why its filling localhost in the URL when trying to update that would be great!

Steps to reproduce

  1. Update through admin ‘open updater’
  2. Update through CLI
  3. Update through /updater

Expected behaviour

  1. Update Starts
  2. Update Starts
  3. Update Starts

Actual behaviour

  1. error: Client error response [url] https://localhost/index.php/occ/config:list [status code] 404 [reason phrase] Not Found (Not on local host?)
  2. Owncloud already at latest version
  3. Invalid password - pasted in from config via putty

Server configuration

{
“basic”: {
“license key”: “REMOVED SENSITIVE VALUE”,
“date”: “Thu, 02 Aug 2018 08:44:54 +0000”,
“ownCloud version”: “10.0.8.5”,
“ownCloud version string”: “10.0.8”,
“ownCloud edition”: “Community”,
“server OS”: “Linux”,
“server OS version”: “Linux boneyard 3.16.0-6-amd64 #1 SMP Debian 3.16.56-1+deb8u1 (2018-05-08) x86_64”,
“server SAPI”: “apache2handler”,
“webserver version”: “Apache”,
“hostname”: “owncloud.REMOVED SENSITIVE VALUE”,
“user count”: 10,
“user directories”: 10,
“logged-in user”: “ldolman”
},
“config”: {
“instanceid”: “occh6h1umz6o”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“owncloud.REMOVED SENSITIVE VALUE
],
“datadirectory”: “/owncloud-data”,
“overwrite.cli.url”: “https://owncloud.REMOVED SENSITIVE VALUE”,
“dbtype”: “mysql”,
“version”: “10.0.8.5”,
“dbname”: “owncloud”,
“dbhost”: “localhost”,
“dbtableprefix”: “oc_”,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“logtimezone”: “UTC”,
“installed”: true,
“maintenance”: false,
“theme”: “”,
“loglevel”: 2,
“//”: “Exclude util - skip checking file flags due to SMB limits”,
“//”: “Exclude util.bak - util overwrites during upgrade”,
“//”: “Exclude Application - skip checking file flags due to SMB limits”,
“integrity.excluded.files”: [
“lib/private/legacy/util.php”,
“lib/private/Console/Application.php”,
“lib/private/legacy/util.bak.php”
],
“singleuser”: false,
“updater.secret”: “REMOVED SENSITIVE VALUE
},
“integritychecker”: {
“passing”: true,
“enabled”: true,
“result”: []
},
“core”: {
“backgroundjobs_mode”: “cron”,
“installedat”: “1513211008.3609”,
“lastcron”: “1533199441”,
“lastupdateResult”: “{“version”:“10.0.9”,“versionstring”:“ownCloud 10.0.9”,“url”:“https:\/\/download.owncloud.org\/community\/owncloud-10.0.9.zip”,“web”:“https:\/\/doc.owncloud.org\/server\/10.0\/admin_manual\/maintenance\/upgrade.html”}”,
“lastupdatedat”: “1533198921”,
“public_files”: “files_sharing/public.php”,
“public_webdav”: “dav/appinfo/v1/publicwebdav.php”,
“updater.secret.created”: “1533198765”,
“vendor”: “owncloud”
},


#2

/owncloud-data is a SMB mount


#3

Hey,

from what i know the “CLI” is only running the database upgrade. You first need to delete all existing files via FTP while keeping the /config and /data folder, then upload the new ownCloud 10.0.9 files and then finally run the CLI command again.