Unable to upload big files - pi 2B - owncloud 10 - raspbian stretch


#1

Hi guys,

I am new to the whole linux environment so I apologize in advance for whatever will come later...

I recently installed owncloud 10 on my raspberry pi 2B. I have a 4To NTFS hard-drive connected to it and I can remotely access it using dns.

I sucessfull manually moved all my files in my owncloud directory but as I tried to upload rather "big" files I can see the loading bar on top that vanishes instantly.

I went through the internet and the owncloud user manual and modified my "php.ini" (one in the /etc/php/7.0/cli/php.ini and one in /etc/php/7.0/fpm/php.ini). I Did the same in the /var/www/html/.user.ini file. Set all upload_max_filesize and post_max_size to 16G, rebooted all the stuff many times and it is still not working...

Also, all the files previously quoted appeared to be in different places than what was descrived elsewhere. Not sure if this is relevant though.

Anyway, thanks for your help. I am kind of desperate here...

Here is the tutorial I used to create my cloud :

Thanks a lot, again !

Argalaprohis


#2

Has raspberry 2b still a 32bit cpus architecture? This might be the technical limitation here.


#3

Hi DeepDiver,
I Just read this this morning. ARM cpus in Pi 2B are actually 32bits...
I will try to set it on 2G rather than 16G when I get home and see what happens.

I will keep you posted !

Thanks mate and have a good day,

Arg


#4

Hi again,

Just changed everything back to "2G". Still not able to load a 700Mo file...


#5

In https://central.owncloud.org/t/your-data-directory-is-readable-by-other-users/10415/9 it was stated that you can't install ownCloud or place its data directory to a NTFS partition.


#6

Hi Tom,

So I should move the data directory to my pi ? Wouldn't this make my NTFS volume unusable ?


#7

I see at this thread that @pmaier1 stated one line below whats required instead: https://central.owncloud.org/t/your-data-directory-is-readable-by-other-users/10415/10


#8

Guess I am kind of screwed then... There are about 3To of data on my drive and I have no mean to move them out while I format the disk...