Untrusted Domain Error

Expected behaviour

I can connect via local to ownCloud. I want to be able to connect via my Cloudfare tunnel to ownCloud. I followed the instructions stating to edit the enironment variables, and not config.php.

Per the recommendations on this forum, I changed /etc/enviornment to:


But it is deleted upon re-starting the container. No result when trying to edit while running.

The value in my volume file config.php does not delete my entry after stopping and starting. It remains as:

  'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => 'cloud.myserver.com',

Actual behaviour

I get the error message “You are accessing the server through an untrusted domain.”

Server configuration

Windows 10 Enterprise

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:
Fresh install

Where did you install ownCloud from:
Link from ownCloud website

Thanks for any help you can provide. I’m new to Docker and doing my best to learn. :slight_smile:

(I attempted to upload the config.php but can’t. And the code within the file was too long to post)

See Untrusted Domain on Asustor Docker installation - #10 by jvillafanez


Thanks for the help.

I tried running that command in Windows command prompt (as an admin) and I get the error

"docker run" requires at least one argument

I looked through the help file and tried a bunch of suggestions I found on forums but can’t get it to work.

I also tried running it under “exec” within Docker Desktop and I get:

docker:not found

I know it has to be something simple but I just can’t figure it out. Thanks again for your help!

I tried different approaches last night, uninstalled and reinstalled owncloud, and still can’t get it to connect. Any ideas? Thanks in advance.

For docker desktop, you can try How to add an environment variable to a container in Docker Desktop? - Super User

According to the link, you’ll have to create a new ownCloud container with the right environment variables, but if it’s a fresh install It shouldn’t be a big deal.

1 Like

YES! It’s working now. Thank you!!

Bummer that you can’t set an env variable after it’s running… I’m thinking this could create problems down the line should I get it all set up, with users added, and find that I need to change another env var…

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.